pia_framework 0.0.5

PIA_FrameWork Flutter package.

0
likes
40 / 110
pub points
0 %
popularity

We analyzed this package on Sep 26, 2020, and awarded it 40 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 33 out of 600 API elements (5.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 280 issues. Showing the first 2:

ERROR: The constructor returns type 'dynamic' that isn't of expected type 'Widget'.

lib/Form/PIA_RangeSlider.dart:87:22

   ╷
87 │                 child: new RangeSlider(
   │ ┌──────────────────────^
88 │ │                 min: min,
89 │ │                 max: max,
90 │ │                 lowerValue: lowerValue,
91 │ │                 upperValue: upperValue,
92 │ │                 divisions: divisions,
93 │ │                 showValueIndicator: showValueIndicator,
94 │ │                 valueIndicatorMaxDecimals: valueIndicatorMaxDecimals,
95 │ │                 onChanged: (double lower, double upper) {
96 │ │                   // call
97 │ │                   callback(lower, upper);
98 │ │                 },
99 │ │               ),
   │ └───────────────^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/Form/PIA_RangeSlider.dart

ERROR: The name 'RangeSlider' is defined in the libraries 'package:flutter/src/material/range_slider.dart (via package:flutter/material.dart)' and 'package:flutter_range_slider/src/flutter_range_slider.dart (via package:flutter_range_slider/flutter_range_slider.dart)'.

lib/Form/PIA_RangeSlider.dart:87:26

   ╷
87 │               child: new RangeSlider(
   │                          ^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/Form/PIA_RangeSlider.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^0.7.00.7.02.3.2+1
carousel_pro^0.0.130.0.131.0.0
connectivity^0.4.3+10.4.9+30.4.9+3
cupertino_icons^0.1.20.1.31.0.0
dio^2.1.22.2.23.0.10
firebase_messaging^4.0.0+34.0.0+47.0.0
flutterflutter0.0.00.0.0
flutter_document_picker^3.0.03.0.14.0.0
flutter_launcher_icons^0.6.10.6.10.8.0
flutter_range_slider^1.3.01.5.01.5.0
flutter_webview_plugin^0.3.40.3.110.3.11
http^0.12.0+20.12.20.12.2
image_crop^0.2.00.2.10.3.3
image_picker^0.5.20.5.4+30.6.7+11
json_annotation^2.0.02.4.03.1.0
overlay_support^0.1.00.1.01.0.5
photo_view^0.3.10.3.30.10.2
pin_entry_text_field^0.1.30.1.40.1.4
shared_preferences^0.4.20.4.30.5.12
stripe_payment^0.1.00.1.11.0.8
Transitive dependencies
PackageConstraintCompatibleLatest
after_layout-1.0.7+21.0.7+2
archive-2.0.132.0.13
args-1.6.01.6.0
characters-1.0.01.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
connectivity_for_web-0.3.1+20.3.1+2
connectivity_macos-0.1.0+50.1.0+5
connectivity_platform_interface-1.0.61.0.6
convert-2.1.12.1.1
cookie_jar-1.0.11.0.1
crypto-2.1.52.1.5
dart_config-0.5.00.5.0
flutter_cache_manager-0.3.21.4.2
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.43.1.4
image-2.1.182.1.18
meta-1.1.81.2.3
path-1.7.01.7.0
path_provider-0.5.0+11.6.18
pedantic-1.9.01.9.2
petitparser-3.0.43.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.21.0.2
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
sqflite-1.3.1+11.3.1+1
sqflite_common-1.0.2+11.0.2+1
string_scanner-1.0.51.0.5
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
uuid-2.2.22.2.2
vector_math-2.0.82.0.8
xml-4.5.14.5.1
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 14 issues. Showing the first 2:

The constraint `^0.7.0` on cached_network_image does not support the latest published version `2.3.2+1`

pubspec.yaml:25:25

   ╷
25 │   cached_network_image: ^0.7.0
   │                         ^^^^^^
   ╵
The constraint `^0.0.13` on carousel_pro does not support the latest published version `1.0.0`

pubspec.yaml:28:17

   ╷
28 │   carousel_pro: ^0.0.13
   │                 ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs