pia_framework 0.0.5

pia_framework #

A new Flutter package.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pia_framework: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pia_framework/pia_framework.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
14
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
20
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Fix lib/Form/PIA_RangeSlider.dart. (-44.59 points)

Analysis of lib/Form/PIA_RangeSlider.dart failed with 2 errors, 3 hints:

line 87 col 22: The constructor returns type 'dynamic' that isn't of expected type 'Widget'.

line 87 col 26: The name 'RangeSlider' is defined in the libraries 'package:flutter/src/material/range_slider.dart' and 'package:flutter_range_slider/src/flutter_range_slider.dart'.

line 4 col 7: Name types using UpperCamelCase.

line 19 col 8: Name non-constant identifiers using lowerCamelCase.

line 37 col 10: Name non-constant identifiers using lowerCamelCase.

Fix lib/Form/PIA_Form.dart. (-15.67 points)

Analysis of lib/Form/PIA_Form.dart reported 34 hints, including:

line 10 col 7: Name types using UpperCamelCase.

line 19 col 35: Name non-constant identifiers using lowerCamelCase.

line 21 col 10: Name non-constant identifiers using lowerCamelCase.

line 22 col 10: Name non-constant identifiers using lowerCamelCase.

line 24 col 10: Name non-constant identifiers using lowerCamelCase.

Fix lib/Chatroom/PIA_Chatroom.dart. (-13.96 points)

Analysis of lib/Chatroom/PIA_Chatroom.dart reported 30 hints, including:

line 4 col 8: Don't import implementation files from another package.

line 13 col 8: Unused import: 'package:pia_framework/View/PIA_WebPage.dart'.

line 17 col 8: Unused import: 'package:pia_framework/Lang/PIA_Lang.dart'.

line 19 col 7: Name types using UpperCamelCase.

line 20 col 6: This function has a return type of 'Widget', but doesn't end with a return statement.

Fix additional 32 files with analysis or formatting issues. (-103.40 points)

Additional issues in the following files:

  • lib/API/PIA_API_Gridlist.dart (21 hints)
  • lib/API/PIA_API_Tablelist.dart (20 hints)
  • lib/Popup/PIA_Alert.dart (17 hints)
  • lib/API/PIA_API_Icon_Count.dart (13 hints)
  • lib/Func/PIA_Animation.dart (13 hints)
  • lib/API/PIA_API_Page.dart (11 hints)
  • lib/Lang/PIA_Lang.dart (11 hints)
  • lib/Payment/PIA_Strip_old.dart (11 hints)
  • lib/View/PIA_UpDown_View.dart (11 hints)
  • lib/API/PIA_API_Widget.dart (7 hints)
  • lib/Form/PIA_DropDownMenu.dart (7 hints)
  • lib/API/PIA_API_Background.dart (6 hints)
  • lib/Firebase/PIA_Firebase.dart (6 hints)
  • lib/Image/PIA_ImagePicker.dart (6 hints)
  • lib/Payment/PIA_Strip.dart (6 hints)
  • lib/API/PIA_API_Popup.dart (5 hints)
  • lib/Func/PIA_Timer.dart (5 hints)
  • lib/Image/PIA_Image.dart (5 hints)
  • lib/Image/PIA_Icon.dart (4 hints)
  • lib/Variable/PIA_Global.dart (4 hints)
  • lib/Popup/PIA_Loading.dart (3 hints)
  • lib/View/PIA_Page.dart (3 hints)
  • lib/File/PIA_FilePicker.dart (2 hints)
  • lib/Func/PIA_Func.dart (2 hints)
  • lib/Image/PIA_ImageCrop_Page.dart (2 hints)
  • lib/Image/PIA_ImageSwapView.dart (2 hints)
  • lib/Image/PIA_PhotoView.dart (2 hints)
  • lib/Lang/PIA_Text.dart (2 hints)
  • lib/Variable/PIA_Temp.dart (2 hints)
  • lib/View/PIA_WebPage.dart (2 hints)
  • lib/Variable/PIA_LocalValue.dart (1 hint)
  • lib/Func/PIA_Facebook.dart (Run flutter format to format lib/Func/PIA_Facebook.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-110 points)

The version constraint in pubspec.yaml does not support the latest published versions for 11 dependencies (cached_network_image, carousel_pro, firebase_messaging, flutter_launcher_icons, image_crop, image_picker, json_annotation, overlay_support, photo_view, shared_preferences, stripe_payment).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and pia_framework.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
cached_network_image ^0.7.0 0.7.0 1.1.1
carousel_pro ^0.0.13 0.0.13 1.0.0
connectivity ^0.4.3+1 0.4.3+7
cupertino_icons ^0.1.2 0.1.2
dio ^2.1.2 2.1.13
firebase_messaging ^4.0.0+3 4.0.0+4 5.1.3
flutter 0.0.0
flutter_document_picker ^3.0.0 3.0.0
flutter_launcher_icons ^0.6.1 0.6.1 0.7.2+1
flutter_range_slider ^1.3.0 1.3.1
flutter_webview_plugin ^0.3.4 0.3.7
http ^0.12.0+2 0.12.0+2
image_crop ^0.2.0 0.2.1 0.3.1
image_picker ^0.5.2 0.5.4+3 0.6.1+3
json_annotation ^2.0.0 2.4.0 3.0.0
overlay_support ^0.1.0 0.1.0 1.0.1
photo_view ^0.3.1 0.3.3 0.4.2
pin_entry_text_field ^0.1.3 0.1.3
shared_preferences ^0.4.2 0.4.3 0.5.3+4
stripe_payment ^0.1.0 0.1.1 0.2.0
Transitive dependencies
after_layout 1.0.7+2
archive 2.0.10
args 1.5.2
async 2.3.0
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
cookie_jar 1.0.1
crypto 2.1.2
dart_config 0.5.0
flutter_cache_manager 0.3.2 1.1.1
http_parser 3.1.3
image 2.1.4
meta 1.1.6 1.1.7
path 1.6.4
path_provider 0.5.0+1 1.2.0
pedantic 1.8.0+1
petitparser 2.4.0
platform 2.2.1
sky_engine 0.0.99
source_span 1.5.5
sqflite 1.1.6+3
string_scanner 1.0.5
synchronized 2.1.0+1
term_glyph 1.1.0
typed_data 1.1.6
uuid 2.0.2
vector_math 2.0.8
xml 3.5.0
yaml 2.1.16
Dev dependencies
flutter_test