stripe_payment 0.2.1

stripe_payment #

A Flutter plugin to integrate the stripe plugin for iOS and Android. Currently only adding a credit card as paymet method is implemented.

Android #

Please be aware that your main activity must extend from FlutterFragmentActivity. Otherwise the Android dialog would've looked very nasty.

Include this into your project's android/gradle.properties file

android.useAndroidX=true
android.enableJetifier=true

Usage #

To set your publishable key set:

import 'package:stripe_payment/stripe_payment.dart';
StripeSource.setPublishableKey("pk_test");

from somewhere in your code, e.g. your main.dart file.

To open the dialog:

StripeSource.addSource().then((String token) {
    print(token); //your stripe card source token
});

TODO #

  • [ ] better error handling
  • [ ] internationalization
  • [ ] more stripe library implementations?

[0.2.1] - 27.08.2019

  • Update Stripe dependencies

[0.2.0] - 13.08.2019

  • BREAKING: This plugin now uses the Payment Intent to create a payment method instead of creating a Source.

[0.1.1] - 07.08.2019

  • Breaking: Minimum Android target is 19 (from 18)
  • Breaking: Minimum iOS target is 9.0 (from 8.0)
  • Update Android Stripe dependency to 10.2.1
  • Update iOS Stripe dependency to 16.0.3

[0.1.0] - 22.02.2019

  • Breaking change: use AndroidX

[0.0.9] - 07.02.2019

  • Updating Android Gradle

[0.0.8] - 08.12.2018

[0.0.7] - 03.12.2018

  • Increase Kotlin and Gradle versions

[0.0.6] - 16.05.2018

  • Dart 2 fixes

[0.0.5] - 20.03.2018

  • Compatible with Flutter SDK >=0.1.4 <2.0.0"

[0.0.4] - 29.01.2018

  • Initial release.

example/README.md

stripe_payment_example #

Demonstrates how to use the stripe_payment plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stripe_payment: ^0.2.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stripe_payment/stripe_payment.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
91
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
95
Learn more about scoring.

We analyzed this package on Sep 19, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8