passkeys 2.0.4 copy "passkeys: ^2.0.4" to clipboard
passkeys: ^2.0.4 copied to clipboard

Flutter plugin enabling simple passkey authentication. Can be either used with a ready-to-use relying party server (Corbado) or with your custom relying party.

30
likes
110/ 140
pub points
86%
popularity

We analyzed this package in the last hour, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

39 out of 94 API elements (41.5 %) have documentation comments.

Some symbols that are missing documentation: authenticator, authenticator.PasskeyAuthenticator.cancelCurrentAuthenticatorOperation, exceptions, exceptions.UnhandledAuthenticatorException.code, exceptions.UnhandledAuthenticatorException.details.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:passkeys/authenticator.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:passkeys/authenticator.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:passkeys/authenticator.dart that declares support for platforms: Android, iOS, Web.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/exceptions.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
convert ^3.1.1 3.1.1 3.1.1
corbado_frontend_api_client ^1.1.0 1.1.0 1.1.0
flutter flutter 0.0.0 0.0.0
json_annotation ^4.8.1 4.8.1 4.8.1
openapi_generator_annotations ^4.10.0 4.13.1 5.0.2
passkeys_android ^2.0.2 2.0.2 2.0.2
passkeys_ios ^2.0.2 2.0.2 2.0.2
passkeys_platform_interface ^2.0.1 2.0.1 2.0.1
passkeys_web ^2.0.1 2.0.1 2.0.1
ua_client_hints ^1.1.3 1.2.2 1.2.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
intl - 0.18.1 0.19.0
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.10.0` on openapi_generator_annotations does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions openapi_generator_annotations to update the constraint.

0/10 points: Package supports latest stable Dart and Flutter SDKs

  • Found no Flutter in your PATH. Could not determine the current Flutter version.

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.

30
likes
110
pub points
86%
popularity

Publisher

verified publishercorbado.com

Flutter plugin enabling simple passkey authentication. Can be either used with a ready-to-use relying party server (Corbado) or with your custom relying party.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

convert, corbado_frontend_api_client, flutter, json_annotation, openapi_generator_annotations, passkeys_android, passkeys_ios, passkeys_platform_interface, passkeys_web, ua_client_hints

More

Packages that depend on passkeys