package_info_plus 1.0.3
package_info_plus: ^1.0.3 copied to clipboard

Flutter plugin for querying information about the application package, such as CFBundleVersion on iOS or versionCode on Android.

130
likes
130 / 130
pub points
98 %
popularity

We analyzed this package on Jun 23, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 11 API elements (90.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with runtime flutter-web on Web

Because:

  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus_linux/package_info_plus_linux.dart that imports:
  • package:package_info_plus_linux/src/package_info.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
package_info_plus_linux^1.0.01.0.21.0.2
package_info_plus_macos^1.0.01.1.11.1.1
package_info_plus_platform_interface^1.0.01.0.11.0.1
package_info_plus_web^1.0.21.0.21.0.2
package_info_plus_windows^1.0.01.0.21.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.7.02.7.0
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
ffi-1.1.21.1.2
flutter_web_plugins-0.0.00.0.0
http-0.13.30.13.3
http_parser-4.0.04.0.0
js-0.6.30.6.3
meta-1.3.01.4.0
path-1.8.01.8.0
plugin_platform_interface-2.0.02.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.2.32.2.3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.

130
likes
130
pub points
98%
popularity

Publisher

fluttercommunity.dev

Flutter plugin for querying information about the application package, such as CFBundleVersion on iOS or versionCode on Android.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

flutter, package_info_plus_linux, package_info_plus_macos, package_info_plus_platform_interface, package_info_plus_web, package_info_plus_windows

More

Packages that depend on package_info_plus