opus_flutter 3.0.2 copy "opus_flutter: ^3.0.2" to clipboard
opus_flutter: ^3.0.2 copied to clipboard

Loads a DynamicLibrary of opus for usage with opus_dart on flutter platforms.

4
likes
160/ 160
pub points
76%
popularity

We analyzed this package 2 days ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2 out of 2 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Web

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:opus_flutter/opus_flutter.dart that declares support for platforms: Android, iOS, Windows, Web.
Package does not support platform `macOS`.

Because:

  • package:opus_flutter/opus_flutter.dart that declares support for platforms: Android, iOS, Windows, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:opus_flutter/opus_flutter.dart that imports:
  • package:opus_flutter/src/opus_flutter_ffi.dart that imports:
  • package:opus_flutter_windows/opus_flutter_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:opus_flutter/opus_flutter.dart that imports:
  • package:opus_flutter/src/opus_flutter_ffi.dart that imports:
  • package:opus_flutter_windows/opus_flutter_windows.dart that declares support for platforms: Windows.
Package does not support platform `Windows`.

Because:

  • package:opus_flutter/opus_flutter.dart that imports:
  • package:opus_flutter/src/opus_flutter_ffi.dart that imports:
  • package:opus_flutter_ios/opus_flutter_ios.dart that declares support for platforms: iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
opus_flutter_android ^3.0.0 3.0.1 3.0.1
opus_flutter_ios ^3.0.0 3.0.0 3.0.0
opus_flutter_platform_interface ^3.0.0 3.0.0 3.0.0
opus_flutter_web ^3.0.3 3.0.3 3.0.3
opus_flutter_windows ^3.0.0 3.0.0 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
inject_js - 2.0.0 2.0.0
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.5 2.2.5
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web_ffi - 0.7.2 0.7.2
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.