openapi_base 1.3.2 copy "openapi_base: ^1.3.2" to clipboard
openapi_base: ^1.3.2 copied to clipboard

Open API base implementation for client/server to be used with openapi_code_builder.

3
likes
130/ 160
pub points
75%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

32 out of 268 API elements (11.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: openapi_base, openapi_base.ApiEndpoint, openapi_base.ApiEndpoint.ApiEndpoint, openapi_base.ApiEndpointCallback, openapi_base.ApiEndpointProvider.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:openapi_base/openapi_base.dart that imports:
  • package:openapi_base/src/server/openapi_shelf_noop_server.dart that imports:
  • package:openapi_base/src/server/openapi_server_base.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
chunked_stream >=1.4.1 <2.0.0 1.4.2 1.4.2
collection >=1.16.0 <2.0.0 1.19.0 1.19.0
http >=0.13.0 <2.0.0 1.2.2 1.2.2
json_annotation >=4.0.0 <6.0.0 4.9.0 4.9.0
logging >=1.0.0 <2.0.0 1.2.0 1.2.0
logging_appenders >=1.0.0 <2.0.0 1.3.1 1.3.1
meta >=1.3.0 <2.0.0 1.15.0 1.15.0
open_api_forked >=3.0.0 <4.0.0 3.0.0+6 3.0.0+6
shelf >=1.0.0 <2.0.0 1.4.2 1.4.2
uri ^1.0.0 1.0.0 1.0.0
uuid >=4.0.0 <5.0.0 4.4.2 4.4.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
clock - 1.1.1 1.1.1
codable_forked - 1.0.0+3 1.0.0+3
crypto - 3.0.3 3.0.3
dio - 5.5.0+1 5.5.0+1
dio_web_adapter - 1.0.1 1.0.1
fixnum - 1.1.0 1.1.0
http_parser - 4.1.0 4.1.0
intl - 0.19.0 0.19.0
matcher - 0.12.16+1 0.12.16+1
path - 1.9.0 1.9.0
quiver - 3.2.1 3.2.1
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.3 0.7.3
typed_data - 1.3.2 1.3.2
web - 1.0.0 1.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 1 error:

  • UNDEFINED_NAMED_PARAMETER - lib/src/server/openapi_shelf_server.dart:55:7 - The named parameter 'poweredByHeader' isn't defined.

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

3
likes
130
pub points
75%
popularity

Publisher

verified publishercodeux.design

Open API base implementation for client/server to be used with openapi_code_builder.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

chunked_stream, collection, http, json_annotation, logging, logging_appenders, meta, open_api_forked, shelf, uri, uuid

More

Packages that depend on openapi_base