open_widgets 0.17.0 copy "open_widgets: ^0.17.0" to clipboard
open_widgets: ^0.17.0 copied to clipboard

A package that implements widgets for mobile and web.

0
likes
80/ 140
pub points
0%
popularity

We analyzed this package 3 hours ago, and awarded it 80 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: open_widgets,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Could not accept branch name: open_widgets.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

29 out of 168 API elements (17.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: base, base.OpenCardClickable, base.OpenCardClickable.OpenCardClickable, base.OpenCardClickable.child, base.OpenCardClickable.height.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:open_widgets/permission/permission.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.
Package does not support platform `macOS`.

Because:

  • package:open_widgets/permission/permission.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.
Package not compatible with platform Web

Because:

  • package:open_widgets/io/io.dart that imports:
  • dart:io

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:open_widgets/permission/permission.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:open_widgets/permission/permission.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 23 issues. Showing the first 2:

WARNING: Unused import: 'dart:math'.

lib/chatbot/chat_page.dart:2:8

  ╷
2 │ import 'dart:math';
  │        ^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/chatbot/chat_page.dart

WARNING: Unused import: '../position/position.dart'.

lib/navigator/mobile_sidebar.dart:4:8

  ╷
4 │ import '../position/position.dart' show FloatingCenterLeft;
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/navigator/mobile_sidebar.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
device_info_plus ^8.0.0 8.2.2 10.1.0
file ^6.1.2 6.1.4 7.0.0
flutter flutter 0.0.0 0.0.0
logger ^1.1.0 1.4.0 2.3.0
path ^1.8.1 1.9.0 1.9.0
path_provider ^2.0.15 2.1.3 2.1.3
permission_handler ^10.2.0 10.4.5 11.3.1
toml ^0.14.0 0.14.0 0.15.0
url_launcher ^6.1.10 6.2.6 6.2.6
velocity_x ^3.6.0 3.6.0 4.2.0
Transitive dependencies
Package Constraint Compatible Latest
auto_size_text_pk - 3.0.0 3.0.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
device_info_plus_platform_interface - 7.0.0 7.0.0
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
intl - 0.17.0 0.19.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
permission_handler_android - 10.3.6 12.0.6
permission_handler_apple - 9.1.4 9.4.4
permission_handler_platform_interface - 3.12.0 4.2.1
permission_handler_windows - 0.1.3 0.2.1
petitparser - 5.4.0 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
url_launcher_android - 6.3.2 6.3.2
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
vxstate - 2.3.0 2.3.0
web - 0.5.1 0.5.1
win32 - 4.1.4 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^8.0.0` on device_info_plus does not support the stable version `9.0.0`.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

The constraint `^6.1.2` on file does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions file to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

0
likes
80
pub points
0%
popularity

Publisher

unverified uploader

A package that implements widgets for mobile and web.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

device_info_plus, file, flutter, logger, path, path_provider, permission_handler, toml, url_launcher, velocity_x

More

Packages that depend on open_widgets