nb_utils 4.4.9
nb_utils: ^4.4.9 copied to clipboard

This package helps you daily usable function and ready made Widgets with ease.

76
likes
110/ 130
pub points
96%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 301 out of 2515 API elements (12.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:nb_utils/nb_utils.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity_plus^1.0.81.4.02.0.2
flutterflutter0.0.00.0.0
fluttertoast^8.0.88.0.88.0.8
shared_preferences^2.0.62.0.82.0.8
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
characters-1.1.01.2.0
collection-1.15.01.15.0
connectivity_plus_linux-1.1.01.1.0
connectivity_plus_macos-1.2.11.2.1
connectivity_plus_platform_interface-1.1.01.1.0
connectivity_plus_web-1.1.0+11.1.0+1
connectivity_plus_windows-1.2.01.2.0
dbus-0.5.60.6.3
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
nm-0.3.00.4.0
path-1.8.01.8.0
path_provider_linux-2.1.02.1.0
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
shared_preferences_linux-2.0.22.0.2
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.22.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.8` on connectivity_plus does not support the stable version `2.0.0`, that was published 16 days ago.

When connectivity_plus is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions connectivity_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

76
likes
110
pub points
96%
popularity

This package helps you daily usable function and ready made Widgets with ease.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

connectivity_plus, flutter, fluttertoast, shared_preferences

More

Packages that depend on nb_utils