nats 0.4.1 icon indicating copy to clipboard operation
nats: ^0.4.1 copied to clipboard

NATS client for Dart language

4
likes
105/ 140
pub points
33%
popularity

We analyzed this package 3 days ago, and awarded it 105 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
15 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Repository URL doesn't exist.

At the time of the analysis https://github.com/security-union/nats-dart was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No CHANGELOG.md found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 26 out of 118 API elements (22.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:nats/nats.dart that imports:
  • package:nats/src/client.dart that imports:
  • package:nats/src/model/tcp_client.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/src/client.dart:97:7

   ╷
97 │       throw new Exception("Client not connected yet, operation not allowed");
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/client.dart

INFO: DO use curly braces for all flow control structures.

lib/src/client.dart:182:7

    ╷
182 │       throw new Exception("Client not connected yet, operation not allowed");
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/client.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build_runner^2.0.12.3.22.3.2
logging^1.0.11.1.01.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-50.0.050.0.0
analyzer-5.2.05.2.0
args-2.3.12.3.1
async-2.10.02.10.0
build-2.3.12.3.1
build_config-1.1.11.1.1
build_daemon-3.1.03.1.0
build_resolvers-2.1.02.1.0
build_runner_core-7.2.77.2.7
built_collection-5.1.15.1.1
built_value-8.4.28.4.2
checked_yaml-2.0.12.0.1
code_builder-4.3.04.3.0
collection-1.17.01.17.0
convert-3.1.13.1.1
crypto-3.0.23.0.2
dart_style-2.2.42.2.4
file-6.1.46.1.4
fixnum-1.0.11.0.1
frontend_server_client-3.2.03.2.0
glob-2.1.12.1.1
graphs-2.2.02.2.0
http_multi_server-3.2.13.2.1
http_parser-4.0.24.0.2
io-1.0.31.0.3
js-0.6.50.6.5
json_annotation-4.7.04.7.0
matcher-0.12.130.12.13
meta-1.8.01.8.0
mime-1.0.31.0.3
package_config-2.1.02.1.0
path-1.8.21.8.2
pool-1.5.11.5.1
pub_semver-2.1.32.1.3
pubspec_parse-1.2.11.2.1
shelf-1.4.01.4.0
shelf_web_socket-1.0.31.0.3
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
stream_channel-2.1.12.1.1
stream_transform-2.1.02.1.0
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
timing-1.0.01.0.0
typed_data-1.3.11.3.1
watcher-1.0.21.0.2
web_socket_channel-2.2.02.2.0
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Dart 2.18.4.

4
likes
105
pub points
33%
popularity

Publisher

verified publisher iconsecurityunion.dev

NATS client for Dart language

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

build_runner, logging

More

Packages that depend on nats