nakama 0.1.6 icon indicating copy to clipboard operation
nakama: ^0.1.6 copied to clipboard

Nakama is an open-source scalable game server that lets you focus on building games.

31
likes
110/ 140
pub points
74%
popularity

We analyzed this package 2 hours ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: [2022-12-01T17:45:22.715629] Starting...
Documenting nakama...
Initialized dartdoc with 569 libraries
Generating docs for library api from package:nakama/rtapi.dart...
Generating docs for library api from package:nakama/api.dart...
Generating docs for library nakama from package:nakama/nakama.dart...
Documented 3 public libraries in 63.3 seconds

stderr:   warning: ambiguous reexport of wrappers.pb.UInt64Value, canonicalization candi[...]
    from wrappers.pb.UInt64Value: (file:///tmp/pub-dartlang-dartdocUSATWO/pkg/li[...]
        api: 1.111 - embeds package name (+1.000), name is long (+0.01000), elem[...]
        api: 1.111 - embeds package name (+1.000), name is long (+0.01000), elem[...]
            Use {@canonicalFor wrappers.pb.UInt64Value} in the desired library's
            documentation to resolve the ambiguity and/or override dartdoc's
            decision, or structure your package so the reexport is less
            ambiguous.  The symbol will still be referenced in all candidates --
            this only controls the location where it will be written and which
            library will be displayed in navigation for the relevant pages. The
            flag --ambiguous-reexport-scorer-min-confidence allows you to set the
            threshold at which this warning will appear.
  warning: ambiguous reexport of wrappers.pb.FloatValue, canonicalization candid[...]
    from wrappers.pb.FloatValue: (file:///tmp/pub-dartlang-dartdocUSATWO/pkg/lib[...]
        api: 1.111 - embeds package name (+1.000), name is long (+0.01000), elem[...]
        api: 1.111 - embeds package name (+1.000), name is long (+0.01000), elem[...]
  warning: ambiguous reexport of empty.pb.Empty, canonicalization candidates: (a[...]
    from empty.pb.Empty: (file:///tmp/pub-dartlang-dartdocUSATWO/pkg/lib/src/api[...]
        api: 1.111 - embeds package name (+1.000), name is long (+0.01000), elem[...]
        api: 1.111 - embeds package name (+1.000), name is long (+0.01000), elem[...]
[...]
    for symbol api.Match.create: (file:///tmp/pub-dartlang-dartdocUSATWO/pkg/lib[...]
    conflicting with file already generated by api.Match.create: (file:///tmp/pu[...]
  error: failed to write file at: api/Match/createRepeated.html
    for symbol api.Match.createRepeated: (file:///tmp/pub-dartlang-dartdocUSATWO[...]
    conflicting with file already generated by api.Match.createRepeated: (file:/[...]
  error: failed to write file at: api/Match/getDefault.html
    for symbol api.Match.getDefault: (file:///tmp/pub-dartlang-dartdocUSATWO/pkg[...]
    conflicting with file already generated by api.Match.getDefault: (file:///tm[...]
  warning: nakama has no library level documentation comments
    from nakama: (file:///tmp/pub-dartlang-dartdocUSATWO/pkg/lib/nakama.dart:1:9)
Found 14 warnings and 25 errors.
Unhandled exception:
encountered 25 errors
#0      Dartdoc.generateDocs (package:dartdoc/src/dartdoc.dart:228:9)
<asynchronous suspension>
#1      pubDartDoc (package:pub_dartdoc/pub_dartdoc.dart:32:19)
<asynchronous suspension>
#2      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:7:52)
<asynchronous suspension>


icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:nakama/nakama.dart that imports:
  • package:nakama/src/nakama_client/nakama_grpc_client.dart that imports:
  • package:grpc/grpc_connection_interface.dart that imports:
  • package:grpc/src/shared/streams.dart that imports:
  • package:http2/transport.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Don't import implementation files from another package.

lib/src/api/proto/google/protobuf/timestamp.pb.dart:13:8

   ╷
13 │ import 'package:protobuf/src/protobuf/mixins/well_known.dart' as $mixin;
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/api/proto/google/protobuf/timestamp.pb.dart

INFO: Don't import implementation files from another package.

lib/src/api/proto/google/protobuf/wrappers.pb.dart:13:8

   ╷
13 │ import 'package:protobuf/src/protobuf/mixins/well_known.dart' as $mixin;
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/api/proto/google/protobuf/wrappers.pb.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
chopper^4.0.14.0.65.1.0
collection^1.16.01.16.01.17.0
fixnum^1.0.01.0.11.0.1
flutterflutter0.0.00.0.0
grpc^3.0.03.1.03.1.0
json_annotation^4.4.04.7.04.7.0
jwt_decoder^2.0.12.0.12.0.1
logging^1.0.21.1.01.1.0
meta^1.7.01.8.01.8.0
protobuf^2.0.02.1.02.1.0
web_socket_channel^2.1.02.2.02.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.3.53.3.5
async-2.10.02.10.0
characters-1.2.11.2.1
convert-3.1.13.1.1
crypto-3.0.23.0.2
googleapis_auth-1.3.11.3.1
http-0.13.50.13.5
http2-2.0.12.0.1
http_parser-4.0.24.0.2
js-0.6.50.6.5
material_color_utilities-0.1.50.2.0
path-1.8.21.8.2
pointycastle-3.6.23.6.2
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
stream_channel-2.1.12.1.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^4.0.1 on chopper does not support the stable version 5.0.0.

Try running dart pub upgrade --major-versions chopper to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

31
likes
110
pub points
74%
popularity

Publisher

verified publisher iconbrunsmann.io

Nakama is an open-source scalable game server that lets you focus on building games.

Homepage
Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

chopper, collection, fixnum, flutter, grpc, json_annotation, jwt_decoder, logging, meta, protobuf, web_socket_channel

More

Packages that depend on nakama