mongo_dart 0.7.0+2
mongo_dart: ^0.7.0+2 copied to clipboard

MongoDB driver, implemented in pure Dart. All CRUD operations, aggregation pipeline and more!

159
likes
110 / 130
pub points
92 %
popularity

We analyzed this package on Jul 29, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 404 out of 1768 API elements (22.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:mongo_dart/mongo_dart.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

lib/mongo_dart.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/connection_pool.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
basic_utils^3.0.03.3.33.3.3
bson^1.0.01.0.31.0.3
collection^1.15.01.15.01.15.0
crypto^3.0.03.0.13.0.1
logging^1.0.01.0.11.0.1
mongo_dart_query^1.0.01.0.21.0.2
path^1.8.01.8.01.8.0
pool^1.5.01.5.01.5.0
rational^1.0.01.2.11.2.1
uuid^3.0.03.0.43.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.1
charcode-1.3.11.3.1
convert-3.0.13.0.1
fixnum-1.0.01.0.0
http-0.13.30.13.3
http_parser-4.0.04.0.0
js-0.6.30.6.3
json_annotation-4.1.04.1.0
meta-1.7.01.7.0
pointycastle-3.2.03.2.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Dart 2.13.4.

159
likes
110
pub points
92%
popularity

MongoDB driver, implemented in pure Dart. All CRUD operations, aggregation pipeline and more!

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

basic_utils, bson, collection, crypto, logging, mongo_dart_query, path, pool, rational, uuid

More

Packages that depend on mongo_dart