leancloud_storage 0.7.10 copy "leancloud_storage: ^0.7.10" to clipboard
leancloud_storage: ^0.7.10 copied to clipboard

An official flutter plugin for LeanCloud storage service base on dart.

9
likes
95/ 140
pub points
73%
popularity

We analyzed this package 9 hours ago, and awarded it 95 pub points (of a possible 140):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

146 out of 285 API elements (51.2 %) have documentation comments.

Some symbols that are missing documentation: leancloud_storage, leancloud_storage.APIVersion, leancloud_storage.CurrentUserKey, leancloud_storage.LCACL.PublicKey, leancloud_storage.LCACL.RoleKeyPrefix.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:leancloud_storage/leancloud.dart that imports:
  • package:dio_http_cache/dio_http_cache.dart that imports:
  • package:dio_http_cache/src/manager_dio.dart that imports:
  • package:dio_http_cache/src/core/manager.dart that imports:
  • package:sqflite/utils/utils.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:leancloud_storage/leancloud.dart that imports:
  • package:dio_http_cache/dio_http_cache.dart that imports:
  • package:dio_http_cache/src/manager_dio.dart that imports:
  • package:dio_http_cache/src/core/manager.dart that imports:
  • package:sqflite/utils/utils.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:leancloud_storage/leancloud.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 87 issues. Showing the first 2:

WARNING: The '?' is unnecessary because 'dynamic' is nullable without it.

lib/internal/http/lc_http_client.dart:72:14

   ╷
72 │       dynamic? data,
   │              ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/internal/http/lc_http_client.dart

WARNING: The '?' is unnecessary because 'dynamic' is nullable without it.

lib/internal/http/lc_http_client.dart:87:14

   ╷
87 │       dynamic? data,
   │              ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/internal/http/lc_http_client.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
convert ^3.0.0 3.1.1 3.1.1
crypto ^3.0.1 3.0.3 3.0.3
dio ^4.0.0 4.0.6 5.4.3+1
dio_http_cache ^0.3.0 0.3.0 0.3.0
flutter flutter 0.0.0 0.0.0
path ^1.8.0 1.9.0 1.9.0
path_provider ^2.0.4 2.1.3 2.1.3
qiniu_flutter_sdk ^0.3.0 0.3.0 0.5.0
shared_preferences ^2.0.5 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 22.0.0 67.0.0
analyzer - 1.7.2 6.4.1
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build - 2.4.1 2.4.1
build_config - 1.0.0 1.1.1
characters - 1.3.0 1.3.0
checked_yaml - 2.0.1 2.0.3
cli_util - 0.3.5 0.4.1
collection - 1.18.0 1.18.0
dart_style - 2.1.1 2.3.6
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
glob - 2.1.2 2.1.2
http_parser - 4.0.2 4.0.2
json_annotation - 4.1.0 4.9.0
json_serializable - 4.1.4 6.7.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
package_config - 2.1.0 2.1.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
pedantic - 1.11.1 1.11.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.1.0 1.2.3
qiniu_sdk_base - 0.3.3 0.5.2
quiver - 3.2.1 3.2.1
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_gen - 1.0.3 1.5.0
source_span - 1.10.0 1.10.0
sqflite - 2.3.3 2.3.3
sqflite_common - 2.5.4 2.5.4
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^0.3.0` on qiniu_flutter_sdk does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions qiniu_flutter_sdk to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

9
likes
95
pub points
73%
popularity

Publisher

verified publisherleancloud.rocks

An official flutter plugin for LeanCloud storage service base on dart.

Homepage

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

convert, crypto, dio, dio_http_cache, flutter, path, path_provider, qiniu_flutter_sdk, shared_preferences

More

Packages that depend on leancloud_storage