lean_sdk_flutter 3.0.5 copy "lean_sdk_flutter: ^3.0.5" to clipboard
lean_sdk_flutter: ^3.0.5 copied to clipboard

Lean SDK Flutter.

3
likes
100/ 160
pub points
66%
popularity

We analyzed this package 38 hours ago, and awarded it 100 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

7 out of 82 API elements (8.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: lean, lean.LeanSDK, lean.LeanSDK.LeanSDK, lean.LeanSDK.connect, lean.LeanSDK.createBeneficiary.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:lean_sdk_flutter/lean_sdk_flutter.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:lean_sdk_flutter/lean_sdk_flutter.dart that imports:
  • package:webview_flutter_android/webview_flutter_android.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:lean_sdk_flutter/lean_sdk_flutter.dart that imports:
  • package:webview_flutter_android/webview_flutter_android.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:lean_sdk_flutter/lean_sdk_flutter.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows, Web.
Package does not support platform `macOS`.

Because:

  • package:lean_sdk_flutter/lean_sdk_flutter.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows, Web.
Package does not support platform `Web`.

Because:

  • package:lean_sdk_flutter/lean_sdk_flutter.dart that imports:
  • package:webview_flutter_android/webview_flutter_android.dart that declares support for platforms: Android.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
permission_handler ^11.0.0 11.3.1 11.3.1
url_launcher ^6.0.9 6.3.0 6.3.0
webview_flutter ^4.2.4 4.8.0 4.8.0
webview_flutter_android ^3.10.1 3.16.4 3.16.4
webview_flutter_wkwebview ^3.8.0 3.14.0 3.14.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
permission_handler_android - 12.0.7 12.0.7
permission_handler_apple - 9.4.5 9.4.5
permission_handler_html - 0.1.1 0.1.1
permission_handler_platform_interface - 4.2.1 4.2.1
permission_handler_windows - 0.2.1 0.2.1
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.1 6.3.1
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 1.0.0
webview_flutter_platform_interface - 2.10.0 2.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 3 errors:

  • UNDEFINED_METHOD - lib/lean_web_client.dart:62:15 - The method 'canLaunchUrl' isn't defined for the type 'LeanWebClient'.
  • UNDEFINED_METHOD - lib/lean_web_client.dart:64:13 - The method 'launchUrl' isn't defined for the type 'LeanWebClient'.
  • UNDEFINED_IDENTIFIER - lib/lean_web_client.dart:64:34 - Undefined name 'LaunchMode'.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.