katana_theme_builder 2.3.4 copy "katana_theme_builder: ^2.3.4" to clipboard
katana_theme_builder: ^2.3.4 copied to clipboard

Building system for katana theme packages. Create a list of image assets from the Asset folder.

0
likes
120/ 140
pub points
18%
popularity

We analyzed this package 23 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

34 out of 36 API elements (94.4 %) have documentation comments.

Some symbols that are missing documentation: katana_theme_builder.ThemeGenerator.throwOnUnresolved, katana_theme_builder.ThemeGenerator.typeChecker.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:katana_theme_builder/katana_theme_builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:katana_theme_builder/katana_theme_builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:katana_theme_builder/katana_theme_builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'isNonNullableByDefault' is deprecated and shouldn't be used. Only non-nullable by default mode is supported.

lib/generator/theme_generator.dart:20:27

   ╷
20 │     if (!element.library!.isNonNullableByDefault) {
   │                           ^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/generator/theme_generator.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^6.0.0 6.5.0 6.5.1
build ^2.3.0 2.4.1 2.4.1
code_builder ^4.2.0 4.10.0 4.10.0
dart_style ^2.2.3 2.3.6 2.3.6
glob ^2.1.1 2.1.2 2.1.2
katana ^2.14.0 2.14.0 2.14.0
katana_builder ^2.1.7 2.1.7 2.1.7
katana_theme_annotation ^2.2.4 2.2.4 2.2.4
source_gen ^1.2.2 1.5.0 1.5.0
yaml ^3.1.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 68.0.0 69.0.0
_macros - 0.1.0 0.1.0
args - 2.5.0 2.5.0
asn1lib - 1.5.3 1.5.3
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
encrypt - 5.0.3 5.0.3
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
intl - 0.19.0 0.19.0
js - 0.7.1 0.7.1
logging - 1.2.0 1.2.0
macros - 0.1.0-main.0 0.1.1-main.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.15.0 1.15.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pointycastle - 3.9.1 3.9.1
pub_semver - 2.1.4 2.1.4
recase - 4.1.0 4.1.0
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.1 0.7.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.1.

Check the analysis log for details.

0
likes
120
pub points
18%
popularity

Publisher

verified publishermathru.net

Building system for katana theme packages. Create a list of image assets from the Asset folder.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, code_builder, dart_style, glob, katana, katana_builder, katana_theme_annotation, source_gen, yaml

More

Packages that depend on katana_theme_builder