json_dynamic_widget 7.2.0+6 copy "json_dynamic_widget: ^7.2.0+6" to clipboard
json_dynamic_widget: ^7.2.0+6 copied to clipboard

A library to dynamically generate widgets within Flutter from JSON or other Map-like structures.

229
likes
160/ 160
pub points
91%
popularity

We analyzed this package 4 hours ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2333 out of 5988 API elements (39.0 %) have documentation comments.

Some symbols that are missing documentation: builders, builders.AlignSchema, builders.AlignSchema.AlignSchema, builders.AlignSchema.id, builders.AlignSchema.schema.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
child_builder ^2.0.2 2.0.2 2.0.2
collection ^1.17.1 1.18.0 1.19.0
dynamic_widget_annotation ^1.1.2+6 1.1.2+6 1.1.2+6
execution_timer ^1.1.0+6 1.1.0+6 1.1.0+6
flutter flutter 0.0.0 0.0.0
form_validation ^3.1.1+7 3.1.1+8 3.1.1+8
interpolation ^2.1.2 2.1.2 2.1.2
json_class ^3.0.0+15 3.0.0+16 3.0.0+16
json_conditional ^3.0.1+15 3.0.1+17 3.0.1+17
json_schema ^5.1.7 5.1.7 5.1.7
json_theme ^6.5.0+1 6.5.0+1 6.5.0+1
logging ^1.2.0 1.2.0 1.2.0
meta ^1.12.0 1.12.0 1.15.0
template_expressions ^3.2.0+9 3.2.0+9 3.2.0+9
uuid ^4.1.0 4.4.2 4.4.2
yaml_writer ^2.0.0 2.0.0 2.0.0
yaon ^1.1.4+10 1.1.4+10 1.1.4+10
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
asn1lib - 1.5.3 1.5.3
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
encrypt - 5.0.3 5.0.3
fake_async - 1.3.1 1.3.1
fixnum - 1.1.0 1.1.0
http - 1.2.2 1.2.2
http_parser - 4.0.2 4.1.0
intl - 0.19.0 0.19.0
iregexp - 0.1.2 0.1.2
js - 0.7.1 0.7.1
json_path - 0.7.2 0.7.2
json_theme_annotation - 1.0.3+10 1.0.3+10
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
maybe_just_nothing - 0.5.3 0.5.3
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
pointycastle - 3.9.1 3.9.1
quiver - 3.2.1 3.2.1
rfc_6901 - 0.2.0 0.2.0
rxdart - 0.27.7 0.28.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.3
typed_data - 1.3.2 1.3.2
uri - 1.0.0 1.0.0
vector_math - 2.1.4 2.1.4
web - 1.0.0 1.0.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.