invoiceninja 0.0.5

Flutter Android iOS web

This package makes it easy to sell products in a Flutter app

4
likes
90 / 110
pub points
30 %
popularity

We analyzed this package on Oct 22, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 95 out of 430 API elements (22.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 35 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/models/client.g.dart:9:11

  ╷
9 │ _$_Client _$_$_ClientFromJson(Map<String, dynamic> json) {
  │           ^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/models/client.g.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/models/client.g.dart:60:22

   ╷
60 │ Map<String, dynamic> _$_$_ClientToJson(_$_Client instance) => <String, dynamic>{
   │                      ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/models/client.g.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
freezed_annotation^0.11.00.11.0+10.12.0
http^0.12.20.12.20.12.2
json_serializable^3.2.53.5.03.5.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-11.0.011.0.0
analyzer-0.40.40.40.4
args-1.6.01.6.0
async-2.4.22.5.0-nullsafety.1
build-1.5.01.5.0
build_config-0.4.20.4.2
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
charcode-1.1.31.2.0-nullsafety.1
checked_yaml-1.0.21.0.2
cli_util-0.2.00.2.0
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart_style-1.3.81.3.8
glob-1.2.01.2.0
http_parser-3.1.43.1.4
js-0.6.20.6.2
json_annotation-3.1.03.1.0
logging-0.11.40.11.4
meta-1.3.0-nullsafety.31.3.0-nullsafety.4
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
path-1.7.01.8.0-nullsafety.1
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
sky_engine-0.0.990.0.99
source_gen-0.9.7+10.9.7+1
source_span-1.7.01.8.0-nullsafety.2
string_scanner-1.0.51.1.0-nullsafety.1
term_glyph-1.1.01.2.0-nullsafety.1
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.3
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.11.0` on freezed_annotation does not support the latest published version `0.12.0`

pubspec.yaml:14:23

   ╷
14 │   freezed_annotation: ^0.11.0
   │                       ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

4
likes
90
pub points
30%
popularity

Publisher

invoiceninja.com

This package makes it easy to sell products in a Flutter app

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, freezed_annotation, http, json_serializable

More

Packages that depend on invoiceninja