inventiv_critic_flutter 0.0.7
inventiv_critic_flutter: ^0.0.7 copied to clipboard

A flutter plugin for Critic integration.

0
likes
60 / 110
pub points
39 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 103 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:inventiv_critic_flutter/api.dart that imports:
  • package:battery/battery.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: A value of type 'bool' can't be returned by the 'onError' handler because it must be assignable to 'FutureOr

lib/critic.dart:52:16

   ╷
52 │         return false;
   │                ^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/critic.dart

lib/api.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
battery^1.0.11.0.112.0.1
connectivity^0.4.8+60.4.9+53.0.3
device_info^0.4.2+40.4.2+102.0.0
dio^3.0.93.0.104.0.0
flutterflutter0.0.00.0.0
http^0.12.10.12.20.13.1
mime^0.9.6+30.9.71.0.0
package_info^0.4.10.4.3+42.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
battery_platform_interface-1.0.02.0.1
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
connectivity_for_web-0.3.1+40.4.0
connectivity_macos-0.1.0+70.2.0
connectivity_platform_interface-1.0.62.0.1
device_info_platform_interface-1.0.12.0.1
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
js-0.6.30.6.3
meta-1.3.01.3.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^1.0.1` on battery does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions battery to update the constraint.

The constraint `^0.4.8+6` on connectivity does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions connectivity to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.