installed_apps 1.5.0 copy "installed_apps: ^1.5.0" to clipboard
installed_apps: ^1.5.0 copied to clipboard

PlatformAndroid

Flutter plugin with utility methods related to installed apps on device.

63
likes
140/ 140
pub points
94%
popularity

We analyzed this package 18 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

10 out of 27 API elements (37.0 %) have documentation comments.

Some symbols that are missing documentation: app_info, app_info.AppInfo, app_info.AppInfo.AppInfo, app_info.AppInfo.builtWith, app_info.AppInfo.AppInfo.create.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:installed_apps/installed_apps.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:installed_apps/installed_apps.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:installed_apps/installed_apps.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:installed_apps/installed_apps.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:installed_apps/installed_apps.dart that declares support for platforms: Android.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

63
likes
140
pub points
94%
popularity

Publisher

verified publishersharmadhiraj.com

Flutter plugin with utility methods related to installed apps on device.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on installed_apps