installed_apps 0.0.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 47

Installed Apps #

Get list of installed apps. (Currently only Android is supported)

Getting Started #

Import package

import 'package:installed_apps/installed_apps.dart';
import 'package:installed_apps/app_info.dart';

Get list of installed apps #

List<AppInfo> apps = await InstalledApps.getInstalledApps();

Start app with package name #

InstalledApps.startApp("com.sharmadhiraj.installed_apps")

Open app settings screen (App Info) with package name #

InstalledApps.openSettings("com.sharmadhiraj.installed_apps")

More updates coming soon !!! #

0.0.1 #

  • Get list of installed app
  • Start app with package name

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:installed_apps/app_info.dart';
import 'package:installed_apps/installed_apps.dart';

void main() => runApp(App());

class App extends MaterialApp {
  @override
  Widget get home => HomeScreen();
}

class HomeScreen extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
        appBar: AppBar(title: const Text("Installed Apps Example")),
        body: FutureBuilder<List<AppInfo>>(
            future: InstalledApps.getInstalledApps(),
            builder: (BuildContext buildContext,
                AsyncSnapshot<List<AppInfo>> snapshot) {
              return snapshot.hasData
                  ? ListView.builder(
                      itemCount: snapshot.data.length,
                      itemBuilder: (context, index) {
                        AppInfo app = snapshot.data[index];
                        return ListTile(
                          title: Text(app.name),
                          onTap: () => InstalledApps.startApp(app.packageName),
                          onLongPress: () =>
                              InstalledApps.openSettings(app.packageName),
                        );
                      })
                  : Center(child: Text("Getting installed apps ...."));
            }));
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  installed_apps: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:installed_apps/installed_apps.dart';
  
Version Uploaded Documentation Archive
0.0.4 Apr 3, 2019 Go to the documentation of installed_apps 0.0.4 Download installed_apps 0.0.4 archive
0.0.3 Apr 2, 2019 Go to the documentation of installed_apps 0.0.3 Download installed_apps 0.0.3 archive
0.0.2 Apr 2, 2019 Go to the documentation of installed_apps 0.0.2 Download installed_apps 0.0.2 archive
0.0.1 Apr 2, 2019 Go to the documentation of installed_apps 0.0.1 Download installed_apps 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
85
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

20 out of 20 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test