injectable_generator 1.1.2
injectable_generator: ^1.1.2 copied to clipboard

Dart native

Injectable is a convenient code generator for get_it. Inspired by Angular DI, Guice DI and inject.dart.

24
likes
60 / 110
pub points
91 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 130 API elements (5.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:injectable_generator/builder.dart that imports:
  • package:injectable_generator/generators/injectable_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Unused import: 'package:injectable/injectable.dart'.

lib/models/dependency_config.dart:4:8

  ╷
4 │ import 'package:injectable/injectable.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/models/dependency_config.dart

INFO: Unnecessary new keyword.

lib/models/dispose_function_config.dart:27:12

   ╷
27 │       return new DisposeFunctionConfig(
   │ ┌────────────^
28 │ │       isInstance: isInstance ?? this.isInstance,
29 │ │       name: name ?? this.name,
30 │ │       importableType: importableType ?? this.importableType,
31 │ │     );
   │ └─────^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/models/dispose_function_config.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.40.10.40.61.1.0
build^1.0.01.6.21.6.3
code_builder^3.6.03.6.03.6.0
collection^1.14.81.14.131.15.0
dart_style^1.3.91.3.101.3.14
glob^1.1.71.2.02.0.0
injectable^1.1.21.1.21.1.2
meta^1.1.81.2.41.3.0
path^1.6.01.7.01.8.0
source_gen^0.9.00.9.10+20.9.10+3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.017.0.0
args-1.6.02.0.0
async-2.4.22.5.0
built_collection-4.3.25.0.0
built_value-7.1.08.0.0
charcode-1.1.31.2.0
cli_util-0.2.00.3.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
file-5.2.16.1.0
fixnum-0.10.111.0.0
get_it-5.0.66.0.0
intl-0.16.10.17.0
js-0.6.20.6.3
logging-0.11.41.0.0
matcher-0.12.90.12.10
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
pedantic-1.9.21.10.0
pub_semver-1.4.42.0.0
quiver-2.1.53.0.0
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.40.1` on analyzer does not support the stable version `0.41.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.1.7` on glob does not support the stable version `2.0.0`, that was published 25 days ago.

When glob is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions glob to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

24
likes
60
pub points
91%
popularity

Injectable is a convenient code generator for get_it. Inspired by Angular DI, Guice DI and inject.dart.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

milad.akarie@gmail.com

License

MIT (LICENSE)

Dependencies

analyzer, build, code_builder, collection, dart_style, glob, injectable, meta, path, source_gen

More

Packages that depend on injectable_generator