i69n 1.1.0
i69n: ^1.1.0 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

Simple internationalization tool for Dart and Flutter, based on YAML files and source code generation.

19
likes
100 / 110
pub points
75 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 27 API elements (29.6 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/i69n.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/i69n_impl.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build^1.2.01.6.21.6.3
build_config^0.4.10.4.60.4.6
dart_style>=1.2.0 <2.0.01.3.121.3.14
yaml^2.2.02.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.017.0.0
analyzer-0.41.21.1.0
args-2.0.02.0.0
async-2.5.02.5.0
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.03.0.0
file-6.1.06.1.0
glob-2.0.02.0.0
json_annotation-4.0.04.0.0
logging-1.0.01.0.0
meta-1.3.01.3.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pub_semver-2.0.02.0.0
pubspec_parse-0.1.81.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.2.0` on yaml does not support the stable version `3.0.0`, that was published 26 days ago.

When yaml is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions yaml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Dart 2.12.0.

19
likes
100
pub points
75%
popularity

Publisher

fnx.io

Simple internationalization tool for Dart and Flutter, based on YAML files and source code generation.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

build, build_config, dart_style, yaml

More

Packages that depend on i69n