gradual_stepper 1.0.0
gradual_stepper: ^1.0.0 copied to clipboard

Flutter Android iOS Linux macOS web Windows

A flutter stepper widget for selecting values in natural ways. Ideal for amount selection.

1
likes
100 / 110
pub points
57 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 26 API elements (80.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
intl^0.16.10.16.10.17.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.16.1` on intl does not support the latest published version `0.17.0`

pubspec.yaml:14:9

   ╷
14 │   intl: ^0.16.1
   │         ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

1
likes
100
pub points
57%
popularity

A flutter stepper widget for selecting values in natural ways. Ideal for amount selection.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

mcm.chadly@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter, intl

More

Packages that depend on gradual_stepper