gradual_stepper 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 80

gradual_stepper #

A real world useful widget for selecting values in natural ways.

Created & Maintained by #

Moustapha Chadly

Highly inspired from #

Usage #

Example

To use this package :

  • Add the dependency to your pubspec.yaml file.
  dependencies:
    flutter:
      sdk: flutter
    gradual_stepper:
  • Usage example.
import 'package:gradual_stepper/gradual_stepper.dart';
// ...
Container(
  padding: const EdgeInsets.all(8.0),
  child: GradualStepper(
    initialValue: 0,
    minimumValue: -100,
    maximumValue: 100,
    stepValue: 2,
    onChanged: (int value) => print('new value $value'),
  ),
),
// ...

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

1.0.0 #

  • Release version.

0.0.1 #

  • Initial version.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:gradual_stepper/gradual_stepper.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Gradual Stepper Demo',
      home: MyHomePage(),
    );
  }
}

class MyHomePage extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      backgroundColor: Colors.blueGrey[900],
      body: Center(
        child: Container(
          padding: const EdgeInsets.all(8.0),
          child: GradualStepper(
            initialValue: 0,
            minimumValue: -100,
            maximumValue: 100,
            stepValue: 2,
            onChanged: (int value) => print('new value $value'),
          ),
        ),
      ), // This trailing comma makes auto-formatting nicer for build methods.
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  gradual_stepper: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:gradual_stepper/gradual_stepper.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
60
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
80
Learn more about scoring.

We analyzed this package on Jul 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • gradual_stepper that is a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
intl ^0.16.1 0.16.1
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
path 1.7.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test