gradual_stepper 1.0.0
gradual_stepper: ^1.0.0 copied to clipboard

A flutter stepper widget for selecting values in natural ways. Ideal for amount selection.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:gradual_stepper/gradual_stepper.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Gradual Stepper Demo',
      home: MyHomePage(),
    );
  }
}

class MyHomePage extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      backgroundColor: Colors.blueGrey[900],
      body: Center(
        child: Container(
          padding: const EdgeInsets.all(8.0),
          child: GradualStepper(
            initialValue: 0,
            minimumValue: -100,
            maximumValue: 100,
            stepValue: 2,
            onChanged: (int value) => print('new value $value'),
          ),
        ),
      ), // This trailing comma makes auto-formatting nicer for build methods.
    );
  }
}
1
likes
100
pub points
47%
popularity

A flutter stepper widget for selecting values in natural ways. Ideal for amount selection.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

mcm.chadly@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter, intl

More

Packages that depend on gradual_stepper