google_maps_routes 1.1.2 icon indicating copy to clipboard operation
google_maps_routes: ^1.1.2 copied to clipboard

A package for drawing routes on Google Maps by using the Google Directions API.

9
likes
140/ 140
pub points
82%
popularity

We analyzed this package 15 hours ago, and awarded it 140 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 16 API elements (31.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:google_maps_routes/google_maps_routes.dart that imports:
  • package:google_maps_routes/src/distance_calculator.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:google_maps_routes/google_maps_routes.dart that imports:
  • package:google_maps_routes/src/distance_calculator.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:google_maps_routes/google_maps_routes.dart that imports:
  • package:google_maps_routes/src/distance_calculator.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:google_maps_routes/google_maps_routes.dart that imports:
  • package:google_maps_routes/src/distance_calculator.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `iOS`.

Because:

  • package:google_maps_routes/google_maps_routes.dart that imports:
  • package:google_maps_routes/src/distance_calculator.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that imports:
  • package:google_maps_flutter_android/google_maps_flutter_android.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_polyline_points^1.0.01.0.01.0.0
google_maps_flutter^2.0.32.2.32.2.3
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
collection-1.17.01.17.1
flutter_plugin_android_lifecycle-2.0.72.0.7
google_maps_flutter_android-2.4.32.4.3
google_maps_flutter_ios-2.1.132.1.13
google_maps_flutter_platform_interface-2.2.52.2.5
http-0.13.50.13.5
http_parser-4.0.24.0.2
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
path-1.8.31.8.3
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
stream_transform-2.1.02.1.0
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

9
likes
140
pub points
82%
popularity

Publisher

verified publisher iconaikenahac.com

A package for drawing routes on Google Maps by using the Google Directions API.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, flutter_polyline_points, google_maps_flutter

More

Packages that depend on google_maps_routes