giphy_get 3.0.5 icon indicating copy to clipboard operation
giphy_get: ^3.0.5 copied to clipboard

Pick EMOJI,STICKER or GIF from Giphy in pure dart code. Support Android,iOS,Web and Desktop.

63
likes
100/ 130
pub points
94%
popularity

We analyzed this package 17 hours ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 356 API elements (5.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
10 / 30icon to trigger folding of the section

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

WARNING: The '!' will have no effect because the receiver can't be null.

lib/src/views/tab/giphy_tab_bar.dart:36:28

   ╷
36 │     WidgetsBinding.instance!.addPostFrameCallback((_) {
   │                            ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/views/tab/giphy_tab_bar.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/client/client.dart:17:16

   ╷
17 │   final String _random_id;
   │                ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/client/client.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
extended_image^6.0.16.2.16.2.1
flutterflutter0.0.00.0.0
flutter_localizationsflutter0.0.00.0.0
flutter_staggered_grid_view^0.6.00.6.10.6.1
http^0.13.30.13.40.13.4
meta^1.3.01.7.01.7.0
provider^6.0.06.0.26.0.2
url_launcher^6.0.186.1.26.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
characters-1.2.01.2.1
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.16.01.16.0
crypto-3.0.23.0.2
extended_image_library-3.3.03.3.0
ffi-1.2.11.2.1
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
http_client_helper-2.0.22.0.2
http_parser-4.0.04.0.0
intl-0.17.00.17.0
js-0.6.40.6.4
material_color_utilities-0.1.40.1.5
nested-1.0.01.0.0
path-1.8.11.8.1
path_provider-2.0.102.0.10
path_provider_android-2.0.142.0.14
path_provider_ios-2.0.92.0.9
path_provider_linux-2.1.62.1.6
path_provider_macos-2.0.62.0.6
path_provider_platform_interface-2.0.42.0.4
path_provider_windows-2.0.62.0.6
platform-3.1.03.1.0
plugin_platform_interface-2.1.22.1.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.01.2.0
typed_data-1.3.11.3.1
url_launcher_android-6.0.176.0.17
url_launcher_ios-6.0.166.0.16
url_launcher_linux-3.0.13.0.1
url_launcher_macos-3.0.13.0.1
url_launcher_platform_interface-2.0.52.0.5
url_launcher_web-2.0.112.0.11
url_launcher_windows-3.0.13.0.1
vector_math-2.1.22.1.2
win32-2.6.12.6.1
xdg_directories-0.2.0+10.2.0+1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.12, Flutter 3.0.0, Dart 2.17.0.

63
likes
100
pub points
94%
popularity

Publisher

unverified uploader

Pick EMOJI,STICKER or GIF from Giphy in pure dart code. Support Android,iOS,Web and Desktop.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

extended_image, flutter, flutter_localizations, flutter_staggered_grid_view, http, meta, provider, url_launcher

More

Packages that depend on giphy_get