game_scaffold 0.3.3
game_scaffold: ^0.3.3 copied to clipboard

A new Flutter package project.

0
likes
100/ 130
pub points
25%
popularity

We analyzed this package on Oct 23, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 27 out of 93 API elements (29.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:game_scaffold/game_scaffold.dart that imports:
  • package:game_scaffold/src/widgets.dart that imports:
  • package:game_scaffold/src/state_hooks.dart that imports:
  • package:game_scaffold_dart/game_scaffold_dart.dart that imports:
  • package:game_scaffold_dart/src/core.dart that imports:
  • package:game_scaffold_dart/src/core/core.dart that imports:
  • package:game_scaffold_dart/src/core/core/core.dart that imports:
  • package:game_scaffold_dart/src/core/core/generic.dart that imports:
  • package:game_scaffold_dart/src/core/core/game.dart that imports:
  • package:game_scaffold_dart/src/core/backend/game_state.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0
flutterflutter0.0.00.0.0
flutter_hooks^0.16.00.16.00.18.0
flutter_riverpod^0.14.00.14.0+30.14.0+3
game_scaffold_dart^0.3.30.3.40.3.4
hooks_riverpod^0.14.00.14.0+30.14.0+5
logging^1.0.01.0.21.0.2
postgrest^0.0.70.0.80.1.8
realtime_client^0.0.70.0.90.1.11
riverpod^0.14.0+10.14.0+30.14.0+3
supabase^0.0.1-dev.110.0.1-dev.110.2.8
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
crypto-3.0.13.0.1
enum_to_string-2.0.12.0.1
fast_immutable_collections-5.1.37.0.3
freezed_annotation-0.14.30.15.0
gotrue-0.0.70.1.2
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
json_annotation-4.3.04.3.0
jwt_decode-0.3.10.3.1
meta-1.7.01.7.0
mime-1.0.11.0.1
path-1.8.01.8.0
rikulo_commons-5.0.65.0.6
sky_engine-0.0.990.0.99
socket_io-1.0.11.0.1
socket_io_client-1.0.11.0.1
socket_io_common-1.0.11.0.1
source_span-1.8.11.8.1
state_notifier-0.7.10.7.1
stream-3.0.2+33.0.2+3
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
web_socket_channel-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.16.0` on flutter_hooks does not support the stable version `0.17.0`.

Try running dart pub upgrade --major-versions flutter_hooks to update the constraint.

The constraint `^0.0.7` on postgrest does not support the stable version `0.1.0`.

Try running dart pub upgrade --major-versions postgrest to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.