functional_data_generator 1.0.0
functional_data_generator: ^1.0.0 copied to clipboard

Simple and non-intrusive code generator for boilerplate of data types.

2
likes
70 / 130
pub points
68 %
popularity

We analyzed this package on May 8, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 11 API elements (9.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:functional_data_generator/builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/builder.dart:25:5

   ╷
25 │     return null;
   │     ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/builder.dart

INFO: 'getResolvedLibraryByElement' is deprecated and shouldn't be used. Use getResolvedLibraryByElement2() instead.

lib/builder.dart:31:49

   ╷
31 │   final resolvedLibrary = await element.session.getResolvedLibraryByElement(element.library);
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/builder.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^1.1.01.5.01.5.0
build^2.0.02.0.12.0.1
collection^1.15.01.15.01.15.0
functional_data^1.0.01.0.01.0.0
source_gen^0.9.10+40.9.10+41.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-21.0.021.0.0
args-2.1.02.1.0
async-2.6.12.6.1
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
dart_style-1.3.142.0.1
file-6.1.06.1.0
glob-2.0.12.0.1
logging-1.0.11.0.1
meta-1.3.01.3.0
package_config-2.0.02.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pub_semver-2.0.02.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.9.10+4` on source_gen does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions source_gen to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • functional_data_generator that depends on:
  • source_gen that doesn't opt in to null safety
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.16.0, Dart 2.12.4.

2
likes
70
pub points
68%
popularity

Simple and non-intrusive code generator for boilerplate of data types.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

spkersten@gmail.com

License

MIT (LICENSE)

Dependencies

analyzer, build, collection, functional_data, source_gen

More

Packages that depend on functional_data_generator