form_bloc 0.31.0 copy "form_bloc: ^0.31.0" to clipboard
form_bloc: ^0.31.0 copied to clipboard

Easy Form State Management using BLoC pattern. Separate the Form State and Business Logic from the User Interface. Async Validation, Progress, Dynamic fields, and more.

156
likes
130/ 160
pub points
80%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

236 out of 344 API elements (68.6 %) have documentation comments.

Some symbols that are missing documentation: form_bloc, form_bloc.BooleanFieldBlocState, form_bloc.BooleanFieldBlocState.BooleanFieldBlocState, form_bloc.FieldBloc.name, form_bloc.FieldBlocState.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The 'endtemplate' directive has '1' arguments, but only '0' are expected.

lib/src/blocs/field/field_bloc.dart:388:21

    ╷
388 │   /// {@endtemplate form_bloc.FieldBloc.updateExtraData}
    │                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/blocs/field/field_bloc.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bloc ^8.0.1 8.1.4 8.1.4
collection ^1.15.0 1.19.0 1.19.0
equatable ^2.0.3 2.0.5 2.0.5
meta ^1.7.0 1.15.0 1.15.0
rxdart ^0.27.3 0.27.7 0.28.0
uuid ^3.0.4 3.0.7 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
crypto - 3.0.3 3.0.3
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.27.3` on rxdart does not support the stable version `0.28.0`, that was published 0 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

The constraint `^3.0.4` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

156
likes
130
pub points
80%
popularity

Publisher

unverified uploader

Easy Form State Management using BLoC pattern. Separate the Form State and Business Logic from the User Interface. Async Validation, Progress, Dynamic fields, and more.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bloc, collection, equatable, meta, rxdart, uuid

More

Packages that depend on form_bloc