form_bloc 0.31.0 copy "form_bloc: ^0.31.0" to clipboard
form_bloc: ^0.31.0 copied to clipboard

Easy Form State Management using BLoC pattern. Separate the Form State and Business Logic from the User Interface. Async Validation, Progress, Dynamic fields, and more.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add form_bloc

With Flutter:

 $ flutter pub add form_bloc

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  form_bloc: ^0.31.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:form_bloc/form_bloc.dart';
156
likes
130
pub points
80%
popularity

Publisher

unverified uploader

Easy Form State Management using BLoC pattern. Separate the Form State and Business Logic from the User Interface. Async Validation, Progress, Dynamic fields, and more.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bloc, collection, equatable, meta, rxdart, uuid

More

Packages that depend on form_bloc