flutterflow 0.1.1 copy "flutterflow: ^0.1.1" to clipboard
flutterflow: ^0.1.1 copied to clipboard

UI components used by FlutterFlow's code generation.

4
likes
30/ 140
pub points
81%
popularity

We analyzed this package 3 hours ago, and awarded it 30 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flutterflow,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: flutterflow.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
Note: collection is pinned to version 1.18.0 by flutter from the flutter SDK.
See https://dart.dev/go/sdk-version-pinning for details.
failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: flutter pub get failed:
OUT:
Resolving dependencies...
ERR:
Note: collection is pinned to version 1.18.0 by flutter from the flutter SDK.
See https://dart.dev/go/sdk-version-pinning for details.


Because every version of flutter from sdk depends on collection 1.18.0 and flutterflow depends on collection 1.15.0, flutter from sdk is forbidden.
So, because flutterflow depends on flutter from sdk, version solving failed.


You can try the following suggestion to make the pubspec resolve:
* Try upgrading your constraint on collection: flutter pub add collection:^1.18.0

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.