flutterclient 0.0.6 copy "flutterclient: ^0.0.6" to clipboard
flutterclient: ^0.0.6 copied to clipboard

PlatformAndroid

Chico conta a história dos seus clientes por meio das suas transações financeiras.

1
likes
100/ 160
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting flutterclient... Discovering libraries... Linking elements... Precaching local docs for 630376 elements... Initialized dartdoc with 964 libraries Generating docs for library data_harvester.dart from package:flutterclient/data_harvester.dart... Generating docs for library connector_webview.dart from package:flutterclient/connector_webview.dart... Generating docs for library flutterclient.dart from package:flutterclient/flutterclient.dart... Documented 3 public libraries in 88.6 seconds ERR: The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. [4923 more lines]

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:flutterclient/flutterclient.dart that imports:
  • package:flutterclient/data_harvester.dart that imports:
  • package:device_apps/device_apps.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:flutterclient/flutterclient.dart that imports:
  • package:flutterclient/data_harvester.dart that imports:
  • package:device_apps/device_apps.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:flutterclient/flutterclient.dart that imports:
  • package:flutterclient/data_harvester.dart that imports:
  • package:device_apps/device_apps.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:flutterclient/flutterclient.dart that imports:
  • package:flutterclient/data_harvester.dart that imports:
  • package:device_apps/device_apps.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:flutterclient/flutterclient.dart that imports:
  • package:flutterclient/data_harvester.dart that imports:
  • package:device_apps/device_apps.dart that declares support for platforms: Android.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:flutterclient/flutterclient.dart that imports:
  • package:flutterclient/connector_webview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

WARNING: The '!' will have no effect because the receiver can't be null.

lib/data_harvester.dart:264:47

    ╷
264 │       (await DeviceApps.getApp(app.packageName!)),
    │                                               ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/data_harvester.dart

lib/connector_webview.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
after_layout ^1.2.0 1.2.0 1.2.0
battery_info ^1.0.8 1.1.1 1.1.1
battery_plus ^2.1.4 2.2.2 6.0.1
connectivity_plus ^2.3.3 2.3.9 6.0.3
cupertino_icons ^1.0.2 1.0.8 1.0.8
device_apps ^2.2.0 2.2.0 2.2.0
device_info_plus ^3.2.0 3.2.4 10.1.0
flutter flutter 0.0.0 0.0.0
http ^0.13.3 0.13.6 1.2.1
installed_apps ^1.3.1 1.5.0 1.5.0
system_info2 ^2.0.4 2.0.4 4.0.0
webview_flutter ^2.0.13 2.8.0 4.8.0
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
battery_plus_linux - 1.2.0 1.2.0
battery_plus_macos - 1.1.1 1.1.1
battery_plus_platform_interface - 1.2.2 2.0.0
battery_plus_web - 1.1.0 1.1.0
battery_plus_windows - 1.1.3 1.1.3
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
connectivity_plus_linux - 1.3.1 1.3.1
connectivity_plus_macos - 1.2.6 1.2.6
connectivity_plus_platform_interface - 1.2.4 2.0.0
connectivity_plus_web - 1.2.5 1.2.5
connectivity_plus_windows - 1.2.2 1.2.2
dbus - 0.7.4 0.7.10
device_info_plus_linux - 2.1.1 5.0.0
device_info_plus_macos - 2.2.3 5.0.0
device_info_plus_platform_interface - 2.6.1 7.0.0
device_info_plus_web - 2.1.0 5.0.0
device_info_plus_windows - 2.1.1 6.0.0
ffi - 1.2.1 2.1.2
file - 6.1.4 7.0.0
file_utils - 1.0.1 1.0.1
flutter_web_plugins - 0.0.0 0.0.0
globbing - 1.0.0 1.0.0
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nm - 0.5.0 0.5.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
upower - 0.7.0 0.7.0
vector_math - 2.1.4 2.1.4
webview_flutter_android - 2.10.4 3.16.4
webview_flutter_platform_interface - 1.9.5 2.10.0
webview_flutter_wkwebview - 2.9.5 3.13.1
win32 - 2.6.1 5.5.1
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^2.1.4` on battery_plus does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions battery_plus to update the constraint.

The constraint `^2.3.3` on connectivity_plus does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions connectivity_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

1
likes
100
pub points
0%
popularity

Publisher

unverified uploader

Chico conta a história dos seus clientes por meio das suas transações financeiras.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

after_layout, battery_info, battery_plus, connectivity_plus, cupertino_icons, device_apps, device_info_plus, flutter, http, installed_apps, system_info2, webview_flutter

More

Packages that depend on flutterclient