flutter_wordpress_content 1.0.24
flutter_wordpress_content: ^1.0.24 copied to clipboard

Flutter widget to help parse & render WordPress raw content with support for YouTube, SoundCloud and Issuu PDF embed widgets

2
likes
60 / 130
pub points
67 %
popularity

We analyzed this package on May 13, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://github.com/muslimtv/flutter_wordpress_contents was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 124 API elements (2.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_wordpress_content/wp_content.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_web.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/model/Paragraph.dart:101:18

    ╷
101 │       textSpans: List<TextSpan>(),
    │                  ^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/model/Paragraph.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/model/Paragraph.dart:115:18

    ╷
115 │       textSpans: List<TextSpan>(),
    │                  ^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/model/Paragraph.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^2.0.0-rc2.5.13.0.0
flutterflutter0.0.00.0.0
html^0.14.0+30.14.0+40.15.0
html_unescape^1.0.1+31.0.22.0.0
url_launcher^5.1.45.4.06.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.23.1.2
async-2.6.12.6.1
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
csslib-0.16.20.17.0
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_blurhash-0.5.00.6.0
flutter_cache_manager-2.1.23.0.2
flutter_web_plugins-0.0.00.0.0
http-0.13.30.13.3
http_parser-4.0.04.0.0
image-3.0.23.0.2
js-0.6.30.6.3
meta-1.3.01.3.0
octo_image-0.3.01.0.0+1
path-1.8.01.8.0
path_provider-2.0.12.0.1
path_provider_linux-2.0.02.0.0
path_provider_macos-2.0.02.0.0
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.12.0.1
pedantic-1.11.01.11.0
petitparser-4.1.04.1.0
platform-3.0.03.0.0
platform_detect-1.4.02.0.0
plugin_platform_interface-2.0.02.0.0
process-4.2.14.2.1
pub_semver-1.4.42.0.0
rxdart-0.25.00.27.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+32.0.0+3
sqflite_common-2.0.0+22.0.0+2
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.12.0.2
url_launcher_web-0.1.32.0.0
uuid-3.0.43.0.4
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.2.00.2.0
xml-5.1.05.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.0.0-rc` on cached_network_image does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^0.14.0+3` on html does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions html to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

2
likes
60
pub points
67%
popularity

Publisher

mta.tv

Flutter widget to help parse & render WordPress raw content with support for YouTube, SoundCloud and Issuu PDF embed widgets

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE.md)

Dependencies

cached_network_image, flutter, html, html_unescape, url_launcher

More

Packages that depend on flutter_wordpress_content