flutter_wallet_card 3.0.4 copy "flutter_wallet_card: ^3.0.4" to clipboard
flutter_wallet_card: ^3.0.4 copied to clipboard

PlatformiOS

Flutter wallet card for iOS devices. Generate Apple Pass card using either locally stored file or download it from web via url.

21
likes
120/ 140
pub points
87%
popularity

We analyzed this package 12 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

81 out of 189 API elements (42.9 %) have documentation comments.

Some symbols that are missing documentation: PasskitBarcode, PasskitBarcode.PasskitBarcode, PasskitBarcode.PasskitBarcode.PasskitBarcode, PasskitBarcode.PasskitBarcode.PasskitBarcode.fromJson, PasskitBarcode.PasskitBarcode.toJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ iOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:flutter_wallet_card/flutter_wallet_card.dart that declares support for platforms: iOS.
Package does not support platform `Windows`.

Because:

  • package:flutter_wallet_card/flutter_wallet_card.dart that declares support for platforms: iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_wallet_card/flutter_wallet_card.dart that declares support for platforms: iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_wallet_card/flutter_wallet_card.dart that declares support for platforms: iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_wallet_card/flutter_wallet_card.dart that declares support for platforms: iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: The file name 'PasskitBarcode.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run flutter analyze lib/models/PasskitBarcode.dart

INFO: The file name 'PasskitField.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run flutter analyze lib/models/PasskitField.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
archive ^3.3.7 3.4.10 3.4.10
cli_script ^1.0.0 1.0.0 1.0.0
crypto ^3.0.3 3.0.3 3.0.3
dio ^5.2.1+1 5.4.3 5.4.3
equatable ^2.0.5 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
path ^1.8.3 1.9.0 1.9.0
path_provider ^2.0.15 2.1.3 2.1.3
uuid ^3.0.7 3.0.7 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.8.0 3.8.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
tuple - 2.0.2 2.0.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.7` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

21
likes
120
pub points
87%
popularity

Publisher

unverified uploader

Flutter wallet card for iOS devices. Generate Apple Pass card using either locally stored file or download it from web via url.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

archive, cli_script, crypto, dio, equatable, flutter, path, path_provider, uuid

More

Packages that depend on flutter_wallet_card