flutter_ume_kit_dio 1.0.1+2 copy "flutter_ume_kit_dio: ^1.0.1+2" to clipboard
flutter_ume_kit_dio: ^1.0.1+2 copied to clipboard

Dio kit for flutter_ume.

2
likes
60/ 140
pub points
90%
popularity

We analyzed this package 7 days ago, and awarded it 60 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

6 out of 13 API elements (46.2 %) have documentation comments.

Some symbols that are missing documentation: flutter_ume_kit_dio, flutter_ume_kit_dio.DioInspector.buildWidget, flutter_ume_kit_dio.DioInspector.dio, flutter_ume_kit_dio.DioInspector.displayName, flutter_ume_kit_dio.DioInspector.iconImageProvider.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

ERROR: The named parameter 'primary' isn't defined.

lib/src/widgets/pluggable_state.dart:27:5

   ╷
27 │     primary: Colors.white,
   │     ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/pluggable_state.dart

ERROR: The getter 'bodyText2' isn't defined for the type 'TextTheme'.

lib/src/widgets/pluggable_state.dart:119:44

    ╷
119 │         style: Theme.of(context).textTheme.bodyText2,
    │                                            ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/pluggable_state.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^4.0.0 4.0.6 5.4.3+1
flutter flutter 0.0.0 0.0.0
flutter_ume >=1.0.0 <2.0.0 1.1.2 1.1.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_localizations - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
intl - 0.19.0 0.19.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences - 2.2.3 2.2.3
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
tuple - 2.0.2 2.0.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 9.4.0 14.2.2
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.