flutter_store_listing 1.0.0 copy "flutter_store_listing: ^1.0.0" to clipboard
flutter_store_listing: ^1.0.0 copied to clipboard

Flutter plugin to handle app reviews with SKStoreReviewController, generate app store links and open them for iOS or android.

2
likes
140/ 160
pub points
72%
popularity

We analyzed this package 6 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

8 out of 18 API elements (44.4 %) have documentation comments.

Some symbols that are missing documentation: flutter_store_listing, flutter_store_listing.FlutterStoreListing, flutter_store_listing.FlutterStoreListing.FlutterStoreListing, flutter_store_listing.FlutterStoreListing.FlutterStoreListing.customize, flutter_store_listing.FlutterStoreListing.defaultUrlCanLaunch.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_store_listing/flutter_store_listing.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_store_listing/flutter_store_listing.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_store_listing/flutter_store_listing.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_store_listing/flutter_store_listing.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:flutter_store_listing/flutter_store_listing.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:flutter_store_listing/flutter_store_listing.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
http >=0.13.0 <2.0.0 1.2.2 1.2.2
logging >=1.0.0 <2.0.0 1.2.0 1.2.0
package_info_plus >=1.0.3 <9.0.0 4.2.0 8.0.0
pedantic >=1.11.0 <2.0.0 1.11.1 1.11.1
url_launcher >=6.0.2 <7.0.0 6.3.0 6.3.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
package_info_plus_platform_interface - 2.0.1 3.0.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
url_launcher_android - 6.3.5 6.3.5
url_launcher_ios - 6.3.1 6.3.1
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.2.0 2.3.1
url_launcher_windows - 3.1.2 3.1.2
vector_math - 2.1.4 2.1.4
web - 1.0.0 1.0.0
win32 - 5.5.1 5.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 4 errors:

  • URI_DOES_NOT_EXIST - lib/flutter_store_listing.dart:10:8 - Target of URI doesn't exist: 'package:url_launcher/url_launcher_string.dart'.
  • UNDEFINED_FUNCTION - lib/flutter_store_listing.dart:35:34 - The function 'canLaunchUrl' isn't defined.
  • UNDEFINED_FUNCTION - lib/flutter_store_listing.dart:38:34 - The function 'launchUrl' isn't defined.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
140
pub points
72%
popularity

Publisher

verified publishercodeux.design

Flutter plugin to handle app reviews with SKStoreReviewController, generate app store links and open them for iOS or android.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

flutter, http, logging, package_info_plus, pedantic, url_launcher

More

Packages that depend on flutter_store_listing