flutter_mylibrary 0.1.76

Flutter Android iOS

library for bibi.

0
likes
60 / 110
pub points
38 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 270 out of 1145 API elements (23.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_mylibrary/flutter_mylibrary.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:flutter_mylibrary/flutter_mylibrary.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS
Package does not support Flutter platform Linux

Because:

  • package:flutter_mylibrary/flutter_mylibrary.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS
Package does not support Flutter platform macOS

Because:

  • package:flutter_mylibrary/flutter_mylibrary.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:flutter_mylibrary/flutter_mylibrary.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:flutter_mylibrary/flutter_mylibrary.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 65 issues. Showing the first 2:

INFO: Unused import: 'package:flutter_easyrefresh/easy_refresh.dart'.

lib/base/bloc/bloc_provider.dart.dart:3:8

  ╷
3 │ import 'package:flutter_easyrefresh/easy_refresh.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/base/bloc/bloc_provider.dart.dart

INFO: Unused import: 'package:flutter_mylibrary/config/const.dart'.

lib/base/bloc/bloc_provider.dart.dart:4:8

  ╷
4 │ import 'package:flutter_mylibrary/config/const.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/base/bloc/bloc_provider.dart.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^2.0.02.3.2+12.3.2+1
connectivity^0.4.8+60.4.9+20.4.9+2
cookie_jar^1.0.11.0.11.0.1
device_info^0.4.2+70.4.2+70.4.2+7
dio^3.0.103.0.103.0.10
dio_cookie_manager^1.0.01.0.01.0.0
dio_http_cache^0.2.90.2.90.2.9
event_bus^1.1.11.1.11.1.1
fbutton^2.0.02.0.12.0.1
fcontrol^1.0.01.0.11.0.1
fluintl^0.1.30.1.30.1.3
flutterflutter0.0.00.0.0
flutter_easyrefresh^2.1.52.1.52.1.5
flutter_localizationsflutter0.0.00.0.0
flutter_spinkit^4.1.24.1.2+14.1.2+1
flutter_swiper^1.1.61.1.61.1.6
flutter_webview_plugin^0.3.110.3.110.3.11
fsuper^0.1.50.1.52.0.2
lpinyin^1.0.71.0.91.0.9
oktoast^2.3.22.3.22.3.2
package_info^0.4.10.4.30.4.3
path_provider^1.6.91.6.161.6.16
provider^4.3.14.3.2+24.3.2+2
rxdart^0.23.10.23.10.24.1
shared_preferences^0.5.7+10.5.100.5.10
shimmer^1.1.11.1.11.1.1
smooth_star_rating^1.1.11.1.11.1.1
synchronized^2.1.0+12.2.0+22.2.0+2
waterfall_flow^2.0.22.0.32.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.09.0.0
analyzer-0.39.170.40.2
args-1.6.01.6.0
async-2.4.22.4.2
build-1.4.01.4.0
build_config-0.4.20.4.2
characters-1.0.01.0.0
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
cli_util-0.2.00.2.0
clock-1.0.11.0.1
collection-1.14.131.14.13
connectivity_for_web-0.3.1+20.3.1+2
connectivity_macos-0.1.0+50.1.0+5
connectivity_platform_interface-1.0.61.0.6
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
cupertino_icons-0.1.31.0.0
dart_style-1.3.61.3.7
device_info_platform_interface-1.0.11.0.1
extended_list_library-2.0.02.0.0
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_blurhash-0.5.00.5.0
flutter_cache_manager-1.4.21.4.2
flutter_page_indicator-0.0.30.0.3
flutter_web_plugins-0.0.00.0.0
glob-1.2.01.2.0
html-0.14.0+30.14.0+3
http-0.12.20.12.2
http_parser-3.1.43.1.4
intl-0.16.10.16.1
js-0.6.20.6.2
json_annotation-3.0.13.0.1
json_serializable-3.4.13.4.1
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.1.81.2.3
nested-0.0.40.0.4
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
octo_image-0.3.00.3.0
package_config-1.9.31.9.3
path-1.7.01.7.0
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+40.0.4+4
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.20.0.2
pedantic-1.9.01.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.21.0.2
process-3.0.133.0.13
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
quiver-2.1.32.1.3
shared_preferences_linux-0.0.2+20.0.2+2
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
sky_engine-0.0.990.0.99
source_gen-0.9.60.9.6
source_span-1.7.01.7.0
sqflite-1.3.1+11.3.1+1
sqflite_common-1.0.2+11.0.2+1
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
transformer_page_view-0.1.60.1.6
typed_data-1.2.01.2.0
uuid-2.2.22.2.2
vector_math-2.0.82.0.8
watcher-0.9.7+150.9.7+15
win32-1.7.11.7.1
xdg_directories-0.1.00.1.2
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.5` on fsuper does not support the latest published version `2.0.2`

pubspec.yaml:34:11

   ╷
34 │   fsuper: ^0.1.5
   │           ^^^^^^
   ╵
The constraint `^0.23.1` on rxdart does not support the latest published version `0.24.1`

pubspec.yaml:29:11

   ╷
29 │   rxdart: ^0.23.1
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs