smooth_star_rating 1.0.4+2

  • Readme
  • Changelog
  • Example
  • Installing
  • 95

A Star rating with touch and swipe rate enabled

  • Supports replacing default star icons with desired IconData
  • Supports half rate and full rate (1.0 or 0.5)
  • Swipe for incrementing/decrementing rate amount
  • Change star body and boundary colors independently
  • Control size of the star rating
  • Set your desired total Star count
  • Supports click-to-rate
  • Spacing between stars

Getting Started #

In your flutter project add the dependency:

    dependencies:
        ...
        smooth_star_rating: 1.0.4+2

Usage example #

import 'package:smooth_star_rating/smooth_star_rating.dart'; 
SmoothStarRating(
          allowHalfRating: false,
          onRatingChanged: (v) {
            rating = v;
            setState(() {});
          },
          starCount: 5,
          rating: rating,
          size: 40.0,
          filledIconData: Icons.blur_off,
          halfFilledIconData: Icons.blur_on,
          color: Colors.green,
          borderColor: Colors.green,
          spacing:0.0
        )

Constructor parameters #

allowHalfRating                 -   Whether to use whole number for rating(1.0  or 0.5)
onRatingChanged(int rating)     -   Rating changed callback
starCount                       -   The maximum amount of stars
rating                          -   The current value of rating
size                            -   The size of a single star
color                           -   The body color of star
borderColor                     -   The border color of star
spacing                         -   Spacing between stars(default is 0.0)
filledIconData                  -   Full Rated Icon
halfFilledIconData              -   Half Rated Icon
defaultIconData                 -   Default Rated Icon

Screenshots #

Full Rating #

alt text

Half Rating #

alt text

MIT LICENSE #

Let me know if you find any bugs/issues.Thanks. #

[1.0.4+2] - 29/12/2019

Bug fixed for issue #19 (Another exception was thrown: 'package:flutter/src/rendering/wrap.dart': Failed assertion: line 122 pos 15: 'spacing != null': is not true.) #

[1.0.4+1] - 26/12/2019

Added support for replacing default stars icon #

The method 'toDouble' was called on null bug fixed #

[1.0.4] - 26/12/2019

Added support for replacing default stars icon #

The method 'toDouble' was called on null bug fixed #

[1.0.3] - 29/05/2019

Added support for a spacing between stars #

[1.0.2] - 29/03/2019

assertion added for checking nullability of rating variable which causes the exception "The method '_greaterThanFromInteger' was called on null."

[1.0.1] - 21/11/2018

Added click-to-rate feature #

[0.0.2] - 02/09/2018

rating bug fixed #

[0.0.1] - 02/09/2018

initial release. #

example/README.md

example #

Smooth rating bar example project.

Getting Started #

Check out the example source code from here.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  smooth_star_rating: ^1.0.4+2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:smooth_star_rating/smooth_star_rating.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
99
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
95
Learn more about scoring.

We analyzed this package on Jan 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Fix lib/smooth_star_rating.dart. (-0.50 points)

Analysis of lib/smooth_star_rating.dart reported 1 hint:

line 4 col 8: Duplicate import.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test