flutter_map_tile_caching 3.0.2
flutter_map_tile_caching: ^3.0.2 copied to clipboard

Plugin for flutter_map to provide an easy way to cache tiles and download map regions for offline use.

20
likes
110/ 130
pub points
81%
popularity

We analyzed this package on Oct 24, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 71 out of 83 API elements (85.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:flutter_map_tile_caching/flutter_map_tile_caching.dart that imports:
  • package:flutter_map_tile_caching/src/databaseManager.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
background_fetch^1.0.01.0.11.0.1
flutterflutter0.0.00.0.0
flutter_local_notifications^6.0.06.1.19.0.1
flutter_map^0.13.10.13.10.14.0
http^0.13.30.13.40.13.4
latlong2^0.8.00.8.10.8.1
meta^1.3.01.7.01.7.0
path^1.8.01.8.01.8.0
permission_handler^8.1.28.2.58.2.5
queue^3.1.03.1.03.1.0
sqflite^2.0.0+32.0.0+42.0.0+4
synchronized^3.0.03.0.03.0.0
tuple^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
flutter_local_notifications_platform_interface-4.0.15.0.0
http_parser-4.0.04.0.0
intl-0.17.00.17.0
lists-1.0.11.0.1
matcher-0.12.110.12.11
mgrs_dart-2.0.02.0.0
permission_handler_platform_interface-3.7.03.7.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
positioned_tap_detector_2-1.0.41.0.4
proj4dart-2.0.02.0.0
quiver-3.0.1+13.0.1+1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timezone-0.7.00.8.0
transparent_image-2.0.02.0.0
typed_data-1.3.01.3.0
unicode-0.3.10.3.1
vector_math-2.1.02.1.1
wkt_parser-2.0.02.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^6.0.0` on flutter_local_notifications does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions flutter_local_notifications to update the constraint.

The constraint `^0.13.1` on flutter_map does not support the stable version `0.14.0`.

Try running dart pub upgrade --major-versions flutter_map to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.