flutter_gpiod 0.3.1
flutter_gpiod: ^0.3.1 copied to clipboard

Dart package for accessing GPIO using the GPIO character device interface on linux / Android (root required). Supports signal edge listening, active state, open source/drain and (if supported by platf

10
likes
80 / 130
pub points
63 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 43 out of 61 API elements (70.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:flutter_gpiod/flutter_gpiod.dart that imports:
  • package:flutter_gpiod/src/gpiod.dart that imports:
  • package:flutter_gpiod/src/bindings.dart that imports:
  • package:flutter_gpiod/src/bindings/libc64_bindings.g.dart that imports:
  • dart:ffi
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^0.1.30.1.31.1.2
meta^1.1.81.7.01.7.0
path^1.7.01.8.01.8.0
tuple^1.0.31.0.32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
matcher-0.12.100.12.10
quiver-2.1.53.0.1
stack_trace-1.10.01.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.3` on ffi does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

The constraint `^1.0.3` on tuple does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions tuple to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

10
likes
80
pub points
63%
popularity

Publisher

ardera.dev

Dart package for accessing GPIO using the GPIO character device interface on linux / Android (root required). Supports signal edge listening, active state, open source/drain and (if supported by platform) bias.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffi, meta, path, tuple

More

Packages that depend on flutter_gpiod