flutter_data 0.8.1
flutter_data: ^0.8.1 copied to clipboard

The seamless way to work with persistent data models in Flutter. Inspired by Ember Data and ActiveRecord.

187
likes
120/ 130
pub points
74%
popularity

We analyzed this package on Sep 22, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 149 out of 396 API elements (37.6 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^1.7.01.7.22.3.0
async^2.6.12.8.22.8.2
build^2.0.22.1.02.1.0
build_resolvers^2.0.32.0.42.0.4
collection^1.15.01.15.01.15.0
crypto^3.0.13.0.13.0.1
equatable^2.0.22.0.32.0.3
glob^2.0.12.0.12.0.1
hive^2.0.42.0.42.0.4
http^0.13.30.13.30.13.3
inflection3^0.5.3+20.5.3+20.5.3+2
json_annotation^4.0.14.1.04.1.0
meta^1.3.01.7.01.7.0
path^1.8.01.8.01.8.0
pubspec_parse^1.0.01.1.01.1.0
riverpod^0.14.0+30.14.0+30.14.0+3
source_gen^1.0.11.0.31.1.0
state_notifier^0.7.00.7.10.7.1
uuid^3.0.43.0.43.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.026.0.0
args-2.3.02.3.0
charcode-1.3.11.3.1
checked_yaml-2.0.12.0.1
cli_util-0.3.30.3.3
convert-3.0.13.0.1
dart_style-2.1.12.2.0
file-6.1.26.1.2
graphs-2.1.02.1.0
http_parser-4.0.04.0.0
logging-1.0.21.0.2
package_config-2.0.22.0.2
pool-1.5.01.5.0
pub_semver-2.1.02.1.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.7.0` on analyzer does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.1+1, Dart 2.14.1.