flutter_data 0.5.0

Dart native js
Flutter Android iOS web

The seamless way to work with persistent data models in Flutter. Inspired by Ember Data and ActiveRecord.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  flutter_data: ^0.5.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_data/flutter_data.dart';
119
likes
100
pub points
74%
popularity

Publisher

flutterdata.dev

The seamless way to work with persistent data models in Flutter. Inspired by Ember Data and ActiveRecord.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

analyzer, async, build, build_resolvers, data_state, glob, hive, http, inflection2, meta, path, pubspec_parse, riverpod, source_gen, state_notifier, uuid

More

Packages that depend on flutter_data