flutter_chat_ui 1.4.4
flutter_chat_ui: ^1.4.4 copied to clipboard

Actively maintained, community-driven chat UI implementation with an optional Firebase BaaS.

231
likes
130/ 130
pub points
94%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 173 out of 182 API elements (95.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
diffutil_dart^2.0.0+12.0.0+12.0.0+1
equatable^2.0.32.0.32.0.3
flutterflutter0.0.00.0.0
flutter_chat_types^3.1.43.1.43.1.4
flutter_link_previewer^2.5.22.5.22.5.2
intl^0.17.00.17.00.17.0
meta^1.3.01.7.01.7.0
photo_view^0.12.00.12.00.13.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
csslib-0.17.10.17.1
flutter_linkify-5.0.25.0.2
flutter_web_plugins-0.0.00.0.0
html-0.15.00.15.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
json_annotation-4.3.04.3.0
linkify-4.1.04.1.0
path-1.8.01.8.0
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher-6.0.126.0.12
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.42.0.4
url_launcher_windows-2.0.22.0.2
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0` on photo_view does not support the stable version `0.13.0`, that was published 10 days ago.

When photo_view is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions photo_view to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

231
likes
130
pub points
94%
popularity

Publisher

flyer.chat

Actively maintained, community-driven chat UI implementation with an optional Firebase BaaS.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

diffutil_dart, equatable, flutter, flutter_chat_types, flutter_link_previewer, intl, meta, photo_view

More

Packages that depend on flutter_chat_ui