flame_audio 0.0.1
flame_audio: ^0.0.1 copied to clipboard

Flutter Android iOS Linux macOS web Windows

Audio support for the Flame game engine. This is currently WIP and will be the place where all audio related code will live in the future.

3
likes
100 / 110
pub points
71 %
popularity

We analyzed this package on Feb 27, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
audioplayers^0.15.10.15.10.17.4
flame>=0.23.0 <1.0.00.28.00.29.3
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
box2d_flame-0.4.60.4.6
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
ffi-0.1.31.0.0
file-5.2.16.1.0
flare_dart-2.3.42.3.4
flare_flutter-2.0.62.0.6
flutter_web_plugins-0.0.00.0.0
intl-0.16.10.17.0
meta-1.3.0-nullsafety.31.3.0
ordered_set-2.0.22.0.2
path-1.7.01.8.0
path_provider-1.6.272.0.0
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.0
path_provider_windows-0.0.4+32.0.0
platform-2.2.13.0.0
plugin_platform_interface-1.0.32.0.0
process-3.0.134.1.0
sky_engine-0.0.990.0.99
synchronized-2.2.0+23.0.0
typed_data-1.3.0-nullsafety.31.3.0
uuid-2.2.23.0.0
vector_math-2.1.0-nullsafety.32.1.0
win32-1.7.4+12.0.0
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.15.1` on audioplayers does not support the stable version `0.16.0`.

Try running dart pub upgrade --major-versions audioplayers to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

3
likes
100
pub points
71%
popularity

Publisher

flame-engine.org

Audio support for the Flame game engine. This is currently WIP and will be the place where all audio related code will live in the future.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

audioplayers, flame, flutter

More

Packages that depend on flame_audio