firebase_chat 0.0.4
firebase_chat: ^0.0.4 copied to clipboard

Fully functional package for Cloud Firestore that makes easier to implement chat in your application

15
likes
90 / 130
pub points
79 %
popularity

We analyzed this package on May 8, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 206 API elements (7.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:firebase_chat/firebase_chat.dart that imports:
  • package:firebase_chat/presentation/base_chat_page.dart that imports:
  • package:gallery_previewer/gallery_previewer.dart that imports:
  • package:gallery_previewer/src/gallery_view_item.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_web.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^7.0.07.0.07.0.0
cached_network_image^3.0.03.0.03.0.0
cloud_firestore^1.0.31.0.72.0.0
equatable^2.0.02.0.02.0.0
firebase_storage_repository^0.0.2+10.0.30.0.3
firestore_repository^0.0.20.0.20.0.2
flutterflutter0.0.00.0.0
flutter_bloc^7.0.07.0.07.0.0
gallery_previewer^0.0.2+10.0.2+10.0.2+1
http^0.13.10.13.30.13.3
intl^0.17.00.17.00.17.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.23.1.2
async-2.6.12.6.1
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
cloud_firestore_platform_interface-4.0.35.0.0
cloud_firestore_web-1.0.72.0.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
firebase_core-1.1.01.1.0
firebase_core_platform_interface-4.0.04.0.0
firebase_core_web-1.0.21.0.2
firebase_storage-8.0.58.0.5
firebase_storage_platform_interface-2.0.32.0.3
firebase_storage_web-1.0.51.0.5
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.0.13.0.1
flutter_pagewise-1.2.32.0.1
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.04.0.0
image-3.0.23.0.2
js-0.6.30.6.3
meta-1.3.01.3.0
nested-1.0.01.0.0
octo_image-1.0.0+11.0.0+1
path-1.8.01.8.0
path_provider-2.0.12.0.1
path_provider_linux-2.0.02.0.0
path_provider_macos-2.0.02.0.0
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.12.0.1
pedantic-1.11.01.11.0
petitparser-4.1.04.1.0
photo_manager-1.1.61.1.6
photo_view-0.11.10.11.1
platform-3.0.03.0.0
plugin_platform_interface-2.0.02.0.0
process-4.2.14.2.1
provider-5.0.05.0.0
rxdart-0.26.00.27.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+32.0.0+3
sqflite_common-2.0.0+22.0.0+2
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.43.0.4
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.2.00.2.0
xml-5.1.05.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.3` on cloud_firestore does not support the stable version `2.0.0`, that was published 3 days ago.

When cloud_firestore is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.