file_testing 2.1.0
file_testing: ^2.1.0 copied to clipboard

Dart native
Flutter Android iOS

Testing utilities for package:file

1
likes
70 / 110
pub points
89 %
popularity

We analyzed this package on Jan 26, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/google/file.dart/packages/file_testing was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 11 API elements (90.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:file_testing/file_testing.dart that imports:
  • package:file_testing/src/testing/core_matchers.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'package:test_api/test_api.dart' is deprecated and shouldn't be used. package:test_api is not intended for general use. Please use package:test..

lib/src/testing/core_matchers.dart:7:1

  ╷
7 │ import 'package:test_api/test_api.dart';
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/testing/core_matchers.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.1.21.2.41.2.4
test_api^0.2.20.2.18+10.2.18+1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
boolean_selector-2.0.02.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
matcher-0.12.90.12.9
path-1.7.01.7.0
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
stream_channel-2.0.02.0.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs