fast_i18n 2.2.1
fast_i18n: ^2.2.1 copied to clipboard

Flutter Android iOS Linux macOS Windows

Lightweight i18n solution. Use JSON files to create typesafe translations.

15
likes
90 / 110
pub points
82 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 27 API elements (25.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:fast_i18n/fast_i18n.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

lib/builder.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/fast_i18n.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build^1.5.01.6.21.6.3
flutterflutter0.0.00.0.0
glob^1.2.01.2.02.0.0
recase^3.0.03.0.13.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.017.0.0
analyzer-0.41.21.1.0
args-1.6.02.0.0
async-2.4.22.5.0
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
cli_util-0.2.00.3.0
collection-1.15.0-nullsafety.31.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
file-5.2.16.1.0
intl-0.16.10.17.0
js-0.6.20.6.3
logging-0.11.41.0.0
meta-1.3.0-nullsafety.31.3.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.7.01.8.0
pedantic-1.9.21.10.0
pub_semver-1.4.42.0.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.2.0` on glob does not support the stable version `2.0.0`, that was published 25 days ago.

When glob is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions glob to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

15
likes
90
pub points
82%
popularity

Publisher

tienisto.com

Lightweight i18n solution. Use JSON files to create typesafe translations.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

build, flutter, glob, recase

More

Packages that depend on fast_i18n