essential_components 1.9.18
essential_components: ^1.9.18 copied to clipboard

Dart js
Flutter web

A library for AngularDart developers. This library will implement several key components for the fast development of web applications with AngularDart.

7
likes
80 / 110
pub points
41 %
popularity

We analyzed this package on Jan 16, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 302 out of 1434 API elements (21.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:essential_components/essential_components.dart that imports:
  • package:essential_components/src/select_tree_dialog/select_tree_dialog.dart that imports:
  • package:essential_components/src/modal/modal.dart that imports:
  • dart:html
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 36 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used.

lib/src/datepicker/day_picker.dart:58:17

   ╷
58 │     var dates = List<DateTime>(n);
   │                 ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/datepicker/day_picker.dart

INFO: 'List' is deprecated and shouldn't be used.

lib/src/datepicker/month_picker.dart:48:18

   ╷
48 │     var months = List<DisplayedDate>(12);
   │                  ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/datepicker/month_picker.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular>=5.3.0 <6.2.06.0.16.0.1
angular_forms>=2.1.2 <4.0.03.0.03.0.0
angular_router>=2.0.0-alpha <4.0.02.0.02.0.0
dart_browser_loader^0.0.6+10.0.6+10.0.6+1
decimal>=0.3.5 <2.5.00.3.50.3.5
essential_rest>=1.0.18 <2.5.01.1.221.1.22
essential_xlsx>=1.0.0 <2.5.01.1.01.1.0
http>=0.12.0 <2.0.00.12.20.12.2
intl>=0.15.8 <2.5.00.16.10.16.1
js^0.6.1+10.6.20.6.2
sass_builder>=2.1.2 <2.5.02.1.32.1.3
xml>=3.7.0 <4.0.03.7.04.5.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.014.0.0
analyzer-0.40.60.41.2
angular_ast-1.0.11.0.1
angular_compiler-1.0.11.0.1
archive-2.0.132.0.13
args-1.6.01.6.0
async-2.4.22.4.2
build-1.6.11.6.1
build_config-0.4.50.4.5
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
charcode-1.1.31.1.3
checked_yaml-1.0.41.0.4
cli_repl-0.2.0+10.2.0+1
cli_util-0.2.00.2.0
code_builder-3.6.03.6.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.101.3.11
file-5.2.15.2.1
fixnum-0.10.110.10.11
glob-1.2.01.2.0
html-0.14.0+40.14.0+4
http_parser-3.1.43.1.4
json_annotation-3.1.13.1.1
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.2.41.2.4
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
package_resolver-1.0.101.0.10
path-1.7.01.7.0
petitparser-3.1.03.1.0
pub_semver-1.4.41.4.4
pubspec_parse-0.1.70.1.7
quiver-2.1.52.1.5
rational-0.3.80.3.8
sass-1.32.41.32.4
source_gen-0.9.10+10.9.10+1
source_maps-0.10.90.10.9
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
stream_transform-1.2.01.2.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
universal_html-1.2.41.2.4
universal_io-1.0.21.0.2
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1
zone_local-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=3.7.0 <4.0.0` on xml does not support the latest published version `4.5.1`

pubspec.yaml:19:8

   ╷
19 │   xml: '>=3.7.0 <4.0.0' #use in feedparser\parser.dart:
   │        ^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

7
likes
80
pub points
41%
popularity

A library for AngularDart developers. This library will implement several key components for the fast development of web applications with AngularDart.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

insinfo2008@gmail.com

License

GPL 3.0 (LICENSE)

Dependencies

angular, angular_forms, angular_router, dart_browser_loader, decimal, essential_rest, essential_xlsx, http, intl, js, sass_builder, xml

More

Packages that depend on essential_components