essential_xlsx 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 67

essential_xlsx #

A library for create Excel XLSX file

dependencies:
    ...
    essential_xlsx: any
    ...

example

 final List<Map<String, dynamic>> data = <Map<String, dynamic>>[
    {'name': 'Isaque', 'phone': '22 2777-2339', 'age': '32'},
    {'name': 'Joe', 'phone': '22 2777-2339', 'age': '32'},
    {'name': 'Leo', 'phone': '22 2777-2339', 'age': '32'},
    {'name': 'Tiago', 'phone': '22 2777-2339', 'age': '32'},
    {'name': 'Jon', 'phone': '22 2777-2339', 'age': '32'},
  ];

  Future<void> toXLSX() async {
    if (data != null) {
      if (data.isNotEmpty) {
        var simplexlsx = SimpleXLSX();
        simplexlsx.sheetName = 'sheet';

        //add data
        var idx = 0;
        data.forEach((item) {
          if (idx == 0) {
            //add titles
            simplexlsx.addRow(item.keys.toList());
          }
          {
            //add values
            simplexlsx.addRow(item.values.map((i) => i.toString()).toList());
          }
          idx++;
        });

        simplexlsx.build();
      }
    }
  }

0.0.4 #

  • Initial version pre alpha

0.0.5 #

  • Fix analysis problems

0.0.6 #

  • Refactoring components names

0.0.7 #

  • Refactoring API names

0.0.8 #

  • Fix bug on DataTable component

0.1.0 #

  • Fix preventDefault and stopPropagation for form submission on enter key

0.1.1 #

  • implementation of a loading animation in dataTable

0.1.2 #

  • implementation directives utils

0.1.3 #

  • fix CSS dataTable

0.1.4 #

  • fix CSS Select Dialog

0.1.6 #

  • implementation onchange event in Select Dialog

0.1.9 #

  • implementation 2 new components "EssentialAccordionComponent" and fontawesome components

0.1.11 #

  • implementation 1 new type on datatable col type

0.1.12 #

  • implementation 1 new components "EssentialModalComponent"

0.1.13 #

  • implementation 1 new components "EssentialDropdownDialogComponent" and fix modal issues

0.1.14 #

  • implementation of RestClient a API for consumer web services

0.1.17 #

  • implementation 1 new components SimpleDialogComponent and fix issues

0.1.18 #

  • implementation 1 new components SimpleLoadingComponent and fix issues

0.1.19 #

  • fix issue on RestClientGeneric, not present totalRecords on result list of getAll

0.1.20 #

  • fix issue on RestClientGeneric, not present totalRecords on result list of getAll

0.1.22 #

  • fix bugs on simple select

0.1.23 #

  • fix bugs

0.1.24 #

  • Timeline Component

0.1.25 #

  • Timeline Component - Bug em renderização corrigida.
  • InnerHTML Componente com DOMSanitizer desbloqueado.

0.1.25 #

  • bug na exibição do timeline

0.1.26 #

  • fix bugs

0.1.31 #

  • implementation of Excel export API

0.1.32 #

  • introduction SimpleXLSX API for Excel export on DataTable

0.1.34 #

  • fix bugs in datePicker and simple select components

0.1.35 #

  • fix bugs on change event of simple select component

0.1.36 #

  • implementation of filter on search fielder of simple select

0.1.41 #

  • fix bugs

0.1.42 #

  • general improvements to DataTable and Rest API

0.1.46 #

  • Dislabe suport in essential select component

0.1.50 #

  • fix DataTable format

0.1.51 #

  • add to DataTable options "visible" and "export" coll settings

0.1.52 #

  • add excel export API

0.1.83 #

  • add EssentialRecaptcha component

1.1.0 #

  • fix documentation and overall bugs

example/README.md

example #

A web app that uses AngularDart and AngularDart Components.

Created from templates made available by Stagehand under a BSD-style license.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  essential_xlsx: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:essential_xlsx/essential_xlsx.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
48
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-native on android

Because of the import of dart:html via the import chain package:essential_xlsx/essential_xlsx.dartpackage:essential_xlsx/src/excel/simple_xlsx.dartdart:html

Package not compatible with runtime flutter-native on ios

Because of the import of dart:html via the import chain package:essential_xlsx/essential_xlsx.dartpackage:essential_xlsx/src/excel/simple_xlsx.dartdart:html

Package not compatible with runtime flutter-native on linux

Because of the import of dart:html via the import chain package:essential_xlsx/essential_xlsx.dartpackage:essential_xlsx/src/excel/simple_xlsx.dartdart:html

Package not compatible with runtime flutter-native on macos

Because of the import of dart:html via the import chain package:essential_xlsx/essential_xlsx.dartpackage:essential_xlsx/src/excel/simple_xlsx.dartdart:html

Package not compatible with runtime flutter-native on windows

Because of the import of dart:html via the import chain package:essential_xlsx/essential_xlsx.dartpackage:essential_xlsx/src/excel/simple_xlsx.dartdart:html

Package not compatible with runtime native-aot

Because of the import of dart:html via the import chain package:essential_xlsx/essential_xlsx.dartpackage:essential_xlsx/src/excel/simple_xlsx.dartdart:html

Package not compatible with runtime native-jit

Because of the import of dart:html via the import chain package:essential_xlsx/essential_xlsx.dartpackage:essential_xlsx/src/excel/simple_xlsx.dartdart:html

Health issues and suggestions

Document public APIs. (-1 points)

10 out of 10 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (xml).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.4.0 <3.0.0
archive >=2.0.13 <3.0.0 2.0.13
xml >=3.7.0 <4.0.0 3.7.0 4.2.0
Transitive dependencies
args 1.6.0
charcode 1.1.3
collection 1.14.13
convert 2.1.1
crypto 2.1.5
meta 1.1.8
path 1.7.0
petitparser 3.0.4
typed_data 1.2.0
Dev dependencies
build_runner any
build_test any
build_web_compilers any
pedantic ^1.7.0
test ^1.6.0